[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 86
  • Last Modified:

network and sub network

my office network is 10.15.192.x, which is surfing enable.
we plug one wireless router to the network port and setting 192.168.2.x as the ip.
Then those pc that connect to this router are able to access the file we share from pc 10.15.192.x.
but pc which is 10.15.192.x can't access to 192.168.2.x share folder.
Any idea?
0
swpui
Asked:
swpui
  • 2
  • 2
1 Solution
 
KimputerCommented:
It's logical when looking at it from this point.

the 10.15.x.x range is connected to the WAN port on the router. The 192.x is considered LAN (internal network). In a conventional sense, the 10.x range is the "internet", while the 192.x is internal. The 192.x should be protected, as you would any normal LAN network. That's why a PC from 192.x can browse the PC at 10.x, but not the other way around. It would mean, the internet would have no problem browsing the LAN. That would be a major security issue.
If you really need this function, you can assign only one PC from the 192.x range to be accessible (but assigning some port forwards to that IP number).

If you think this is way too much work, and anyone on the wifi should be on the same LAN, change the router to an access point role (connect to LAN, instead of WAN, AFTER you disable the DHCP function in the router). Everyone on wifi will now be on the 10.x range, with no file sharing problems (only if you trust all wifi connections).
0
 
Sajid Shaik MSr. System AdminCommented:
it's not possible that one sub net will communicate with other sub net without router...

you can do one thing..

if all pc's are connected with single network cable and accessing both network i.e Lan and Internet..

then go to lan setting - properties - TCP/IP version 4 Properties - Advanced - here add 1 more IP...

i.e
192.168.2.10
10.15.192.10

you can keep both IP's

this way will works fine...

all the best
0
 
swpuiAuthor Commented:
shaik, I tried your method but did not work
0
 
KimputerCommented:
That's because my explanation was the correct one! You didn't adjust your router settings, therefore this issue will remain.
0
 
swpuiAuthor Commented:
Will try this, seems logical
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now