Windows 8 Remote Desktop Port Opening

Posted on 2014-08-18
Last Modified: 2014-11-28
I have a client with a Windows 8.1 brand new computer.  I use no-ip to allow him to remote into the machine while off-site.  He has 3 such machines so each has a different RDP port.  For the life of me I can't get the brand new Windows 8.1 machine to have an open port.  I tried 3388, matter what port I choose, I can't see the port open at canyouseeme.  I turned off the firewall, turned it on and added an exception for one port, range of ports, etc.  I'm at loss here.  I have never had any issues with an XP or Windows 7 machine, seems like something in Windows 8 is causing me an issue.  

Also, I checked the logs on the router and I see it the request getting through there just fine.

Anyone have any suggestions?
Question by:pjnutt
    LVL 77

    Expert Comment

    by:David Johnson, CD, MVP
    on the router you have to enable port forwading for tcp for the applicable port i.e.
    3389 -> pc1, 3390 -> pc2 , 3391 -> pc3.  Since on pc2 and 3 your are using a non standard port you will have to open the firewall and add the port to an allowed incoming port

    Author Comment

    That's the thing.  I have the port forwarding rule setup on the router AND Windows Firewall turned off.  I uninstalled the preloaded Anti-virus, so that's not it!

    Any other ideas?

    Author Comment

    I have also added the rule to open the port in the firewall even though I have it turned off!
    LVL 31

    Expert Comment

    First thing is check to see if you can connect to your Windows 8 machine from another computer on the local network, using your Windows 8 machine's local IP address (e.g. the 192.168.xx.xx IP). If you can, it's a router issue. If you can't, it's a client issue.

    Make sure you have enabled Remote Desktop. Go to the start menu, search for "This PC", right click, Properties, Remote tab, and enable "Allow remote connections to this computer".

    Make sure that your user account has a password, and it must be a member of either the "Administrators" group, or the "Remote Desktop Users" group on the Windows 8 machine.

    Make sure the Windows 8 computer has a static IP address (or a DHCP reservation on your router), and your router is forwarding to the port to that IP.

    RDP runs on TCP port 3389 by default, make sure that is the port you forward.

    Double-check your WAN IP address is correct using

    Make sure when you attempt to connect that you are doing so from an OUTSIDE network. Some routers do not properly support NAT hairpinning and connecting to your WAN IP address from within your own LAN doesn't work.

    Accepted Solution

    This was actually due to NOT having the professional version of Windows 8.1.  Without it, you can not remotely login to a machine,

    Author Closing Comment

    I had to figure this out on my own.  If someone suggested the version of Windows 8.1 NOT being professional, I could have fixed a lot faster.

    Featured Post

    How to run any project with ease

    Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
    - Combine task lists, docs, spreadsheets, and chat in one
    - View and edit from mobile/offline
    - Cut down on emails

    Join & Write a Comment

    Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
    If you use NetMotion Mobility on your PC and plan to upgrade to Windows 10, it may not work unless you take these steps.
    This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…
    Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…

    734 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now