Custom error handling for ASP and IIS 6.0

I got request from PCI compliance agent to create a custom error page for the following error. But it has no error code. I tried with error 500;100 to create a custom page, but still show the same error message. Which error code should I modify to show custom error message in IIS?

========================
xxxxxxx.com/about.asp?pagenumber=2;WAITFOR%20DELAY%20'00:00:21';--


This is the response on the page I got back:
Microsoft VBScript runtime error '800a000d'
Type mismatch: '[string: "2;WAITFOR DELAY '00:"]'
C:\INETPUB\WWWROOT\xxxxxxx\INCLUDES\../content/cnt_about.asp, line 6
LVL 1
crcsupportAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Scott Fell, EE MVEDeveloper & EE ModeratorCommented:
What they are saying is to not show detail errors on the page.  You need to turn off sending errors to the browser and you should be good.

You just need to log into iis and turn off "send error to browser"
0
Scott Fell, EE MVEDeveloper & EE ModeratorCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
crcsupportAuthor Commented:
I found it at website/home directory/configuration.

thanks!!
0
Scott Fell, EE MVEDeveloper & EE ModeratorCommented:
Great.  They just don't want to see the detailed errors.   The reason is it helps hackers.

Another common thing you must turn off on iis6 is parent paths.  If you have include files that look like below (starting with two dots and the include is "file"), then you have parent paths on.
<!--#include file ="../connections/myconn.asp"-->

Open in new window


Once you turn parent paths off, you will need to change your code to "virtual" and use an absolute path.
<!--#include virtual ="/connections/myconn.asp"-->

Open in new window

If they don't catch it now, they will on another scan.  Might as well bite the bullet and fix this too.
0
crcsupportAuthor Commented:
ok, thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.