Why are non windows ntp clients not updating from a windows ntp server?

Our non windows ntp clients are not receiving time updates.  Why?

Scenario:

MAINT2 is our NTP server.  It is a Windows 2003 which reaches out to time.windows.com for the time.

Our PDC gets the time from MAINT2.  All other domain desktops and servers get their time from our PDC.  This portion works as expected.

All NON Windows equipment is pointed to MAINT2 for the time.  Non Windows equipment includes printers, VOIP phones, network equipment etc.

The non Windows equipment is not receiving updates.  It did work at one time until we realized MAINT2 was not actually reaching the Internet for the time due to a firewall issue.  Since we corrected MAINT2 being able to reach the time server on the Internet the non Windows clients are not getting time updates.

Using WireShark we can see the one way conversation between a phone and MAINT2.  The phone makes a time request but MAINT2 does not reply back.

We've tried every idea we have come across but still no luck.  Any ideas?  Is there some kind of authentication getting in the way?
LVL 1
dalvaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

giltjrCommented:
Are you sure that your Windows server is setup as a NTP server and not just a Windows Time Server.

When the Windows machines are making a time query are they actually using NTP (TCP port 123)?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
frankhelkCommented:
From your symptoms I would think that your master is in Windows time server only mode, too.

But if you like to use NTP (a excellent choice, btw), why not consider to use the "real thing" - a Windows port of the *ux NTP daemon ? Easy to install, simple to config, precise, stable as a rock and with the footprint of an ant.

See my article on NTP for more details and don't hesitate to ask me for assistance if needed.
0
dalvaAuthor Commented:
giltjr,

This morning everything is now working as expected.  We tweaked a few reg settings such as "PhaseCorrectRate"=dword:00000007 from a 2 to a 7 but we're not certain what made it start working.

What is the difference between a Windows time server and an NTP server on a Windows server?  We used w32tm to set things up.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

dalvaAuthor Commented:
frankhelk,
I read your article.  It answered the difference between Windows time server and Windows NTP server.

If we start having issues again, we'll yank Windows time server and find a Windows NTP application to use.
0
giltjrCommented:
Not sure if this will work in a Active Directory environment, but here is how to make a standalone Windows server a NTP server:

http://www.techrepublic.com/blog/the-enterprise-cloud/configure-a-standalone-ntp-server-in-windows-server/
0
frankhelkCommented:
If you kick W32time, I would recommend the NTP port for Windows by Meinberg (don't forget to grab their "NTP cheat sheet" - very helpful).

I' havn't tried the other flavours around (besides of the Hopf version some years ago), but I have good experience with it and it comes with a pretty installer.

I havn't done an installation for some time now, but I faintly remember that there's a trick when installing the x86 version (the only one ...) on x64 Windows - maybe the installed configuration file ntp.conf ends up in %WINDIR%\SysWOW64\Drivers\etc but is configured in the registry (service NTP, command line) to %WINDIR%\System32\Drivers\etc .... but I'm not sure if that glitch still exists. If so, just move the file to the directory whre it should be (the command line could be inspected in the NTP service settings (Windows services administraion console). But I presume that everything works well when you install it with the plain vanilla default values/locations.
0
dalvaAuthor Commented:
giltjr,
After reading the article about how to make a stand alone NTP Windows server we think we know what happened.  While tweaking various reg settings, my co-worker recalls changing the Enabled from 0 to 1 without really understanding why.  This is the only explanation which makes sense as to why it started working again.  With that in mind, we're closing the ticket and awarding the points to you.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\w32time\TimeProviders\NtpServer]
"InputProvider"=dword:00000000
"AllowNonstandardModeCombinations"=dword:00000001
"DllName"="C:\\WINDOWS\\system32\\w32time.dll"
"Enabled"=dword:00000001
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.