Only print servers can print to certain printers

We have a single print server running Server 2008 R2 64bit (virtual server running on Citrix XenServer 6.1). Everything has been working fine before they went on summer vacation. Coming back we have certain printers that no one can print to *except* the print server itself can print just fine. This includes their RDS farm (Server 2008R2 64 bit VM's) and individual systems that install drivers too (like laptops and desktops that use the print server, they all run Windows 7 Enterprise 64 bit.)  Any ideas where to look? All printers are supported on server 2008R2 (and 2012), fairly new (2 years old at most), and all IP connected.
LVL 8
Casey WeaverNetwork EngineerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Chad FranksSenior System EngineerCommented:
are you using the universal printer drivers?  Also have you restarted the Citrix Print Management and Print Spooler services?
0
Casey WeaverNetwork EngineerAuthor Commented:
We are not using the UPD, only the manufacturer drivers for the printer. Citrix print management services are set to autorestart on failure, all citrix servers have been restarted. Print spooler on the print server (and the print server itself) have been restarted.

This doesn't just affect citrix though, like I said it affects our laptops and desktops too which map printers with GPO's. I took a brand new laptop out of the box, joined it to the domain, then manually added the printer from the print server. Tried to print and it won't, job just disappears to no where (not in the queue of the laptop, or the print server). Go immediately to the print server and print a job to that same printer and it prints just fine.
0
Tony JLead Technical ArchitectCommented:
Can you print to one of the affected printers directly to its IP?

What have you done so far? Anything in the logs? Rebooted the print server? Tried to delete and recreate one of the shared printers?

Do the printers show as offline from the affected clients? If it isn't only affecting Citrix then restarting the Citrix print services won't really do much as you found out.

On the face of it it sounds like a permissions issue.

Send a print job and see if anything is logged on the print server. If you open one of the affected printers and send a job, does it ever appear?

You could try stopping the spooler and deleting all the files in the Windows\system32\spool\printers folder, then restarting it but given you can print from the print server it really doesn't strike me as a stuck print job.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Casey WeaverNetwork EngineerAuthor Commented:
Haven't had a chance to use the printer directly from a system without the print server yet.

Rebooted the print server, checked printer permissions, restarted the spooler, cleared all jobs, haven't checked the even log. Printer shows online and ready to all clients.
0
Tony JLead Technical ArchitectCommented:
Weird. Do the failing printers have anything in common? Model/IP range?

Is it possible someone has updated a driver on either the server or the clients so there's a mismatch?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Casey WeaverNetwork EngineerAuthor Commented:
The driver could be an issue, the printers are still actively covered by their manufacturers. But there doesn't seem to be a model that it targets. IP range is all the same as well (the people and the printers are in different subnets/VLANS but people have no issues printing to the other printers).
0
Tony JLead Technical ArchitectCommented:
I would check the version of driver on the server with that on one of the affected machines.
0
Casey WeaverNetwork EngineerAuthor Commented:
You were right, the systems were pulling a new driver that didn't include our settings (code authentication for department billing). Same driver version, but the generic instead of the customized one from the print server. We contacted the lease company who manages the printers and they pointed out clients were getting authentication errors because their drivers weren't sending the codes. It was pretty easy to figure out from there. Thanks for pointing us in the right direction!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.