Map Drive through Cloud not Showing on Website

I have a cloud windows server 2012. I have a documents server which I have created a map path to D:/
(UPDATE: I can even create a directory on C:/KILL and the same problem. It's not finding the directory/files from the physical path. When I do this locally, it works fine. Just not on the server.)

I have created a virtual directory in IIS and I can see the files in the virtual directory. They exist.

But when I run the web application from a browser, and try to access that directory by going to one of the image files via the URL, it can't find anything. If I try to access via a physical path, D:/Documents/ it also does not find it that way either.

This is a Rackspace server on the cloud. Does anyone know if there are settings we need that we're missing?

virtual directory in IIS with files showing
If I try to go there directly through my URL, like so:
http://websitename.com/Documents/CMSDocs/trademark2.png
I get this error:
500 - Internal server error.
There is a problem with the resource you are looking for, and it cannot be displayed.

if I go through the physical path, it doesn't seem to recognize anything there either.

Any ideas?

thanks!
LVL 2
Starr DuskkASP.NET VB.NET DeveloperAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
is d:\documents located on the Rackspace server and did you change the security on the folder d:\documents (ntfs permissions) to give the web server access to that folder and sub folders with at least read access?
0
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
yes, it is on the rackspace server.

And as far as permissions, how do I go about doing that?

I do notice that when I used a directory in my project, I would setup permissions on the Users (APP-1\Users) account for ability to create folders, read, write, etc.

But with this drive, this account doesn't exist. Here is a screenshot. On the left is the project directory permissions. And on the right is the error when I try to paste in this user:

users
how do I setup the proper "web user" permissions on this mapped drive?

thanks!
0
David Johnson, CD, MVPOwnerCommented:
add the everyone account in both the share and the ntfs permissions will full read access
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
I logged in as an admin to the server.
I right clicked the mappathed Docs network connection and added permissions for Everyone. I set it to full control just for good measure.
I opened the Documents directory inside this connection and did the same thing.
I created a virtual path in my IIS web site. I right clicked and set the permissions on it the same.

However, nothing appears from the web site. I reset the website via IIS.

If I change the path to something on the webserver, like C://Kill/Documents, it does work (with permissions). But it doesn't work on this network.

So when you say "both the share and the ntfs permission" did I cover it all? or am I still missing something?

thanks!
0
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
any ideas?
0
David Johnson, CD, MVPOwnerCommented:
have you tried using the full address instead of the mapped drive i.e.
\\ipaddress\sharename ?
0
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
yes, I did. thank you. That didn't work.

I'm thinking maybe there is something to do with permissions on the load balancer? But I don't know anything about that stuff, so I don't know.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
David Johnson, CD, MVPOwnerCommented:
Glad you found out the problem..
0
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
It was the load balancer. Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.