get access to drive D on remote workstation

I have a computer in my network that I cannot open and browse drive D remotely(I am domain admin). It seems that someone removed the permissions for domain admins for this disk. Drive C: is accessible. Computer is WinXP.
I tried from computer management to share it again but unsuccessful.
Any idea how to access drive D on this computer, or how can I give myself permissions for this(as I said I am domain admin). Computer is on remote location and so it's not accessible onsite.
dedriAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rhandelsCommented:
Are you able to RDP into the machine? If so, take ownership of the D drive, normally this should be enough to get permissions back. If you can't RDP into it there is no way to get the permissions back other than reinstall the machine. D share is made automatically as an administrative share.
0
dedriAuthor Commented:
RDP is not enabled
psexec remotecomputer cmd  is working , is it possible to use some command line commmand to gain permissions?
0
rhandelsCommented:
You could try the following link. You could either use icacls or takeown. Problem is that you need to take ownership of the D drive. It is worth giving it a shot.

http://www.winhelponline.com/blog/take-ownership-of-file-or-folder-windows-7-vista/
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

Lionel MMSmall Business IT ConsultantCommented:
if psexec is working then try this command
Net Share DriveD=D:\ /Grant:AdminUser,Full /Grant:"Domain Admins",Full /Remark:"Root of D:\"
this will create a share on D:\ giving the group "domain admins" and a Admin User Full Access--replace Adminuser with an actual user--like yours
0
great_gentle_manCommented:
if you have an windows xp computer on your domain available at your Location,  open computer management console and connect to the remote p.c.

first go to disk management in storage and check if the D drive is working in the first place.

If you can see the D drive then go to local user group to verify that domain admins are included in local administrators group. if not include them.

After that go to shares in system tools and verify that d drive have administrative share. if not try to share it.



And also have a look at this link

http://www.sole.dk/how-to-disable-administrative-shares-on-workstations-thru-group-policy-and-avoid-spending-time-on-pesty-virus-infections/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dedriAuthor Commented:
thanks
0
great_gentle_manCommented:
glad we could be of assistance.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.