[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Why is Excel 2013 Hiding Header Bar?

Posted on 2014-08-20
13
Medium Priority
?
257 Views
Last Modified: 2014-08-29
I have just upgraded my computer to Office 2013.  Whenever I go open an Excel 2013 document, I find that the header bar (the bar with A - whatever) is being hidden by the formula bar.  I've tried hiding the formula bar but then the worksheet itself just seems to move upwards so that the header bar is then hidden by the tabs at the top.  I've also tried using the zoom function thinking maybe it was that but it is not.  The only other option I could think of was that the workbook was in "maximized" mode but I can't find the button to minimize the internal window.  

On top of that, I have discovered that when I open a new Excel 2013 document, the header bar appear.  However if I switch into an Excel document that does not have the header bar, then the newly created document will also suddenly hide the header bar as well.  This is driving me bonkers!

I'm attaching a screenshot of the problem.  Does anyone know what is going on, and how I can fix it?  I did not have this problem with Excel 2010.        screenshot of problem
0
Comment
Question by:hogefenton
  • 5
  • 4
  • 3
  • +1
13 Comments
 
LVL 2

Expert Comment

by:Andrew Velasco
ID: 40274050
Hi,

Try this in the offending workbook: File > Options > Advanced.  Under the "Display" Header, make sure "Show Formula Bar" is checked.

Edit: Sorry - I just realized that's not what you are talking about. - you are talking about the column headers.  I apologize.  I will look into this.
0
 
LVL 10

Expert Comment

by:etech0
ID: 40274058
You can also try double clicking on any of the ribbon names (eg: Home) and see if that helps.
0
 
LVL 2

Expert Comment

by:Andrew Velasco
ID: 40274067
Ok, lets try this:
Same section (File > Options > Advanced).  Under the "Display options for this worksheet:", is "Show row and column headers" checked?
0
Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

 
LVL 27

Expert Comment

by:Glenn Ray
ID: 40274239
^ I thought that also, but in his screen shot the row headers are visible.
0
 
LVL 27

Expert Comment

by:Glenn Ray
ID: 40274248
I noticed that you have the KUTOOLS addin.  Have you checked the View Group section, especially the "Show/Hide" options to make sure you aren't hiding the header row with that?

Reference:  
http://www.extendoffice.com/product/kutools-for-excel.html#view


-Glenn
0
 

Author Comment

by:hogefenton
ID: 40274286
@Andrew - Yes, that box is checked to show all column and row headers.

@Glenn - All options within KUTOOLS are to show the appropriate column headers.  

I wish I knew how to make a video of what happens when the worksheet seems to move itself upwards.  It's like it doesn't recognize that the formula bar or the ribbon should be sitting on top of the column headers.
0
 
LVL 2

Expert Comment

by:Andrew Velasco
ID: 40274322
To verify Glenn's theory, can you disable KUTOOLS and restart Excel?
0
 
LVL 27

Expert Comment

by:Glenn Ray
ID: 40274340
I can replicate this appearance in Excel 2010 using VBA:
Excel 2010 - normal window repositioned
This is actually a "normal" - not "maximized" window that is re-positioned to this state.  When the macro runs, the worksheet appears to move into this position, like you described above.

You stated that this is happening for "an Excel 2013 document."  Is this a specific document?  Any chance it is macro-enabled?

BTW, the code to replicate this was:
Sub Mess_It_Up()
    ActiveWindow.WindowState = xlNormal
    With ActiveWindow
        .Top = -36
        .Left = -6
    End With
End Sub

Open in new window


-Glenn
0
 

Author Comment

by:hogefenton
ID: 40274832
@Glenn - That is exactly how my document looks.  It is also happening to any new Excel document that I start from File > New.  It looks fine for a few seconds and then it reverts to the old way.  The old documents may be macro-enabled, however no macros should be running on the workbook.  When I click the File > New I do not believe that is labelled as a macro-enabled workbook.  (I hope I'm not mixing up terms here)
0
 
LVL 27

Accepted Solution

by:
Glenn Ray earned 1500 total points
ID: 40275047
Okay, just a test:

1) Open Excel
2) Does the blank default document appear without a header?
    a) Yes - Click menu items:  View - Arrange All - Cascade  *Does the whole workbook window appear in the Excel workspace?*
        1) Yes - See if there is a Personal.xlsb file in C:\Users\username\AppData\Roaming\Microsoft\Excel\XLSTART.  Consider removing it or check the code for possible repositioning code like shown above.
        2) No - reinstall Excel 2013
    b) No - Close this blank workbook without saving changes.  Create a new, blank workbook ([Ctrl]+[N]).  Repeat step 2 (unless you've tried this already).
0
 

Author Comment

by:hogefenton
ID: 40279077
@Glenn - the view change did not work.  Tried that originally.  

In the end I got fed up and just reinstalled Excel 2013.  That did the trick.  Just annoying that I had to do so.  Such a weird problem!  

Thank you all for all of your direction and help.
0
 

Author Comment

by:hogefenton
ID: 40279493
I've requested that this question be closed as follows:

Accepted answer: 0 points for hogefenton's comment #a40279077
Assisted answer: 400 points for Glenn Ray's comment #a40275047

for the following reason:

Reason is that I did the action before another person could suggest it.  However I also allowed for the fact that Expert Glenn did suggest it, which is why he also got credit for the solution.
0
 
LVL 27

Expert Comment

by:Glenn Ray
ID: 40279494
Hi,
In order to receive any credit - partial as my suggestion may have been - you need to actually click the "Accept this solution" link above my previous post where I provided a solution.  You can then grade and assign points as appropriate.  

Sorry that a re-install was necessary, but I did suspect that may have been needed.  It's possible a registry setting placed the default window position in "negative" positions as I demonstrated with my macro example.

Regards,
-Glenn
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this post, I will showcase the steps for how to create groups in Office 365. Office 365 groups allow for ease of flexibility and collaboration between staff members.
Windows Explorer let you handle zip folders nearly as any other folder: Copy, move, change, and delete, etc. In VBA you can also handle normal files and folders, but zip folders takes a little more - and that you'll find here.
This Micro Tutorial will demonstrate the scrolling table in Microsoft Excel using the INDEX function.
Finds all prime numbers in a range requested and places them in a public primes() array. I've demostrated a template size of 30 (2 * 3 * 5) but larger templates can be built such 210  (2 * 3 * 5 * 7) or 2310  (2 * 3 * 5 * 7 * 11). The larger templa…

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question