Dcdiag Error code 58 server 2003

Error on server 2003 - Not sure what to do from here.  Its my Main server.
DC diag

Performing initial setup:
   [DC1] LDAP search failed with error 58,
   The specified server cannot perform the requested operation..
   ***Error: The machine, SETTEDC1 could not be contacted, because of a bad net
    response.  Check to make sure that this machine is a Domain Controller.

Performing initial setup:
   [sdc1] LDAP search failed with error 58,
   The specified server cannot perform the requested operation..
   ***Error: The machine, sdc1 could not be contacted, because of a bad net
    response.  Check to make sure that this machine is a Domain Controller.

CC:\Documents and Settings\Administrator.company>netdiag

.....................................

    Computer Name: sdc1
    DNS Host Name: sdc1.dp.com
    System info : Microsoft Windows Server 2003 R2 (Build 3790)
    Processor : x86 Family 6 Model 15 Stepping 6, GenuineIntel
    List of installed hotfixes :
@@zRemoved these@@

Netcard queries test . . . . . . . : Passed



Per interface results:

    Adapter : Local Area Connection

        Netcard queries test . . . : Passed

        Host Name. . . . . . . . . : sdc1.dp.com
        IP Address . . . . . . . . : 10.127.238.158
        Subnet Mask. . . . . . . . : 255.255.255.0
        Default Gateway. . . . . . : 10.127.238.254
        Dns Servers. . . . . . . . : 10.127.238.155
                                     10.127.240.247


        AutoConfiguration results. . . . . . : Passed

        Default gateway test . . . : Passed

        NetBT name test. . . . . . : Passed
        [WARNING] At least one of the <00> 'WorkStation Service', <03> 'Messenge
r Service', <20> 'WINS' names is missing.

        WINS service test. . . . . : Skipped
            There are no WINS servers configured for this interface.


Global results:


Domain membership test . . . . . . : Passed


NetBT transports test. . . . . . . : Passed
    List of NetBt transports currently configured:
        NetBT_Tcpip_{6D5C7DE8-6AA5-4543-A13D-1FF295FF026B}
    1 NetBt transport currently configured.


Autonet address test . . . . . . . : Passed


IP loopback ping test. . . . . . . : Passed


Default gateway test . . . . . . . : Passed


NetBT name test. . . . . . . . . . : Passed
    [WARNING] You don't have a single interface with the <00> 'WorkStation Servi
ce', <03> 'Messenger Service', <20> 'WINS' names defined.


Winsock test . . . . . . . . . . . : Passed


DNS test . . . . . . . . . . . . . : Passed
    PASS - All the DNS entries for DC are registered on DNS server '10.127.238.1
55' and other DCs also have some of the names registered.
    PASS - All the DNS entries for DC are registered on DNS server '10.127.240.2
47' and other DCs also have some of the names registered.


Redir and Browser test . . . . . . : Passed
    List of NetBt transports currently bound to the Redir
        NetBT_Tcpip_{6D5C7DE8-6AA5-4543-A13D-1FF295FF026B}
    The redir is bound to 1 NetBt transport.

    List of NetBt transports currently bound to the browser
        NetBT_Tcpip_{6D5C7DE8-6AA5-4543-A13D-1FF295FF026B}
    The browser is bound to 1 NetBt transport.


DC discovery test. . . . . . . . . : Passed


DC list test . . . . . . . . . . . : Passed


Trust relationship test. . . . . . : Skipped


Kerberos test. . . . . . . . . . . : Passed


LDAP test. . . . . . . . . . . . . : Passed
    [FATAL] Cannot open an LDAP session to 'sdc1.dp.com' at '10.1
27.238.158'.
    [WARNING] Failed to query SPN registration on DC 'sdc1.dp.com
'.
    [WARNING] Failed to query SPN registration on DC 'navlexus.dp.com
'.


Bindings test. . . . . . . . . . . : Passed


WAN configuration test . . . . . . : Skipped
    No active remote access connections.


Modem diagnostics test . . . . . . : Passed

IP Security test . . . . . . . . . : Skipped

    Note: run "netsh ipsec dynamic show /?" for more detailed information


The command completed successfully

C:\Documents and Settings\Administrator.company>





C:\Documents and Settings\Administrator.PRESTIGE>netdom query fsmo
Schema owner                SDC1.dp.com

Domain role owner         SDC1.dp.com

PDC role                    SDC1.dp.com

RID pool manager            SDC1.dp.com

Infrastructure owner        SDC1.dp.com

The command completed successfully.
thecookmanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ComputerTechieCommented:
Have you ran Run Netdiag /fix and DCDiag /fix yet to see if  it will fix the issue?
I assume your running exchange on your server too?


CT
0
thecookmanAuthor Commented:
No Exchange,  Both command output are above.

Thank you
0
SteveCommented:
check eventvwr. system, application, directory service & frs sections.

This DC is very unhappy and we need to get a feel whats wrong to help you fix it.

Do you have other DCs? does dcdiag etc run ok on those?
I notice the server shown above is using another server for DNS instead of itself. is this intentional?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ComputerTechieCommented:
Netdiag and dcdiag will both give a different output if you use the /fix switch with them.

Is your dns controlled by a router? If so i recommend you block out some ip address for the server(s) and put then in a special pool for server so it will not assign these ip to devices on the network.

Also did some hardware been.changed such as new switches or a rogue router on your network?

CT
0
thecookmanAuthor Commented:
Hi everyone, did a forece removal of the DC and moved my Fsmo roles to a new server.  
Thank you all for you help.

- Please slit between 2 above.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.