Internal domain name same as external hosted exchange server

Hi,

At a client site i have a server 2012 R2 with domain.nl the external hosted email adres is also domain.nl

With autodiscover the client receive their settings. With Outlook 2013 this works fine, but with outlook 2010 i can't store the credentials in the credential manager. It is stored as sesion so after a reboot or log off outlook keeps prompting for password.

Example:

User logs on with user1@domain.nl on a Win7 client. Now we configure Outlook 2010 with autodisocover withe the same name user1@domain.nl. The credential manager shows persistence as sesion. If i log on with the same user1@domain.nl but configure outlook with user2@domain.nl the password is stored correct.

Please help me on this one. Thanks in advance.
LVL 1
LevixAutomatiseringAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Pushpakumara MahagamageVPCommented:
open credential manager and add record manually, by the way is client pc belongs to that domain, so you don't have to save credential do you? just check route from client pc to exchange server and verify communication is local.
if it's going out from local network you have to correct DNS records on local dns server.

check outlook 2010
http://support.microsoft.com/kb/290684 

http://blog.montopolis.com/2010/10/24/outlook-2010-does-not-save-password-with-exchange/
0
LevixAutomatiseringAuthor Commented:
Thanks for your answer. At my local DNS is set a SRV record which points to the external autodiscover location.

What DNS settings do you recommend?
0
LevixAutomatiseringAuthor Commented:
I solved the problem with a workaround. I created a vault in the credential manager with an other username. Create a backup of the vault en replaced the vault with the correct vault i created.

So for now the customer can work with Outlook without password prompts.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Pushpakumara MahagamageVPCommented:
1.your exchange and autodiscover at external site so your resource record is correct.
2. it seems you have PDC in local network and  exchange at remote site. Do you have one user account for Domain and another for email or create mail box for same local domain user
0
LevixAutomatiseringAuthor Commented:
Great work around.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.