[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 87
  • Last Modified:

Out Of Office not functioning externally

SBS (Exchange 2007) Out Of Office is not functioning externally. (It works internally)

Initially I checked that the out of office was enabled in Exchange, and it was. ("Allow external out-of-office messages and 2003 etc" and "allow automatic replies" and forwards on the format tab. This is the case on both the SBS transport and the default. )

I set up 'expert' level logging on MS Exchange for MSExchangeIS -> 9000 Private -> rules, MSExchangeMailboxAssistants -> OOF Assistant, -> OOF Library and -> Service

After adding the diagnostic logging a warning appeared in the application event log:
Event 1033
"The rule (1-RULENUMBER) with sequence number 50 is being ignored because it is disabled. The distinguished name of the owning mailbox is USERNAME. Database "First Storage Group\Mailbox Database"

Initially there was only one user and not the user who I was sending the test emails too. I presumed the users rule was corrupt and it was effecting all the other users rules.

I therefore tried using MFCMapi on a workstation to connect to the profile concerned and delete_hard_delete the IPM.Rule.Message entries for the user and that user hasn't appeared again in the event log....yet.

However as the minutes pass more warning events are being logged for other users. I tried deleting the rules for the next user but that user continued to have more warnings when I tested the out of office from an external address, so it didn't resolve the issue.

I have also just had an event warning for a user with sequence number 100. If that means anything?

I'm not sure where to go from here. Help appreciated.
0
Graeme Barnett
Asked:
Graeme Barnett
  • 4
  • 2
  • 2
  • +2
1 Solution
 
Mohammed Yusuf PanjriCommented:
Hi,

If OOF is working internally and not just externally, could you let me know if the Autodiscover is working externally.

The Outlook Connect to the OOF URL using Autodiscover service

Alternatively you can also try to check the external URL for EWS

Are you able to set OOF and just OOF message are not getting delivered??
0
 
Adam FarageEnterprise ArchCommented:
Run the following, and please post the results from a user who is connected externally:

- Open Outlook
- In the tray (where the clock is) Ctrl-Right Click the Outlook icon and select "Test E-Mail AutoConfiguration"
- Test this with the same username / password that is open with the Outlook client

Please post the results. As the expert above stated, this is most likely an issue with the Availability service which URL is pulled by external AutoDiscover. We would need to see if AutoDiscover externally is working to figure this out though.
0
 
hecgomrecCommented:
I'm not sure what to tell you about the log errors, but what I have seen so far when users report their out of the office is not working outside but within the organization is that they haven't activated properly the function on their Outlook.

Outlook 2013 for example, you can setup the function to start and finish at a given time automatically and you can even set the function with 2 different messages for within the organization and another one for outside the organization or even not activate the one for outside the organization, more yet you can choose to every single email or just your contacts.

So if you just upgraded your clients and you used to work with 2007 which only needed one message, then this could be your issue.
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
Graeme BarnettAuthor Commented:
Sorry, I wasn't very clear, we don't have external users with outlook clients. The problem is that people like yourself send an email to me and you would not receive an out of office reply, but internal staff do get the auto-replys.

I ran the 'test email autoconfiguration' from an internal client and these were the relevant results:

Exchange HTTP
-------------------
Server: remote.ourdomain.com
Login Name: tuser
SSL: Yes
Availability Service URL: https://remote.ourdomain.com/
OOF URL: https://remote.ourdomain.com/

Exchange RPC
-------------------
Server: Internalservername.ourdomain.local
Availability Service URL: https://remote.ourdomain.com/ews/exchange.asmx
OOF URL: https://remote.ourdomain.com/ews/exchange.asmx

It seems that just producing these results show that autodiscover is working, however, if I try to use Microsoft's Remote Connectivity Analyzer it cannot connect to the auto discovery.

I notice the URLS for Exchange HTTP don't have the full path including the /ews/exchange.asmx. Could that be why it's not working?
0
 
Graeme BarnettAuthor Commented:
Hecgomrec,
There have been no recent upgrades to the clients, and they all know how to use outlook. My out of office isn't working either, I've test several now and they don't work, so I'm guessing it effects everyone and isn't a training issue.
0
 
Adam FarageEnterprise ArchCommented:
Yes - I would run the commands below and tell us what your URL is..

Get-WebServicesVirtualDirectory | FL

Open in new window


Thanks!
0
 
Graeme BarnettAuthor Commented:
Similar to the above test the internal URL includes the EWS but the external doesn't:

Internal URL: https://remote.EXTERNALSERVERNAME.com\ews\exchange.asmx
External URL: https://remote.EXTERNALSERVERNAME.COM\
0
 
hecgomrecCommented:
The assistant must be configured for inside and outside replies, if the outside part is off or is activated only for "My Contacts" the assistant will not sent replies to emails outside the organization, Please check below:


Set out of office with Out of Office Assistant with Exchange Account: (2010-2013)

If you are using an Exchange account, you can auto reply a specified message for the received emails with setting the Out of Office Assistant while you are away. Please do as follows:

1. Click File button in the upper-left corner in outlook 2010, and click Info > Automatic Replies, see screenshot:


Note: If you do not see this Automatic Replies option, your outlook have not connected to an Exchange Server.

2. In the Automatic Replies dialog box, select the Send automatic replies:
        (1.) Check the Only send during this time range, and then specify the Start time and End time you need to auto reply
               the message.
        (2.) Then type your message at the space box.

3. If you want to send auto-reply message to external senders, click on the Outside My Organization tab and check the Auto-reply to people outside my organization option.

4. Click OK to activate the out of office message.

See it here with pics (first part):
http://www.extendoffice.com/documents/outlook/484-outlook-2010-how-to-set-out-of-office-in-outlook-2010.html
0
 
Graeme BarnettAuthor Commented:
Thanks hecgomrec, we are using Outlook 2007 and it's setup correctly.
0
 
pjk00Commented:
Something I recently ran into using a hosted Exchange solution. (Intermedia)

If a user is using both Automatic Replies and Inbox Rules (ie server-side rules that automatically file an incoming message into a folder based on criteria like sender address), the Automatic Reply will NOT fire for any message which has been acted on by such a rule.

Apparently the Automatic Reply logic expects to see the message hit the inbox first, and the Inbox Rule moves the message into a different folder before it ever touches the inbox.

Quite honestly I find this kind of shockingly poor design, since this renders Auto Reply close to useless for any user that uses inbox rules - and typically inbox rules are used to act on some of the most common messages received, meaning in many cases the bulk of incoming email traffic will never trigger an Auto Reply.

So in the author's case - if the users are using Inbox Rules for messages originating externally, this could explain why the Auto Replies are not triggering for those messages.

I don't know if this is an Intermedia or Microsoft issue, but it seems like a Microsoft issue so far.
0

Featured Post

Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

  • 4
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now