RDS 2012 R2 Unable to connect to published desktop via RD Web Access

I've got a client that I'm trying to setup RDS.  I have everything working and can login via RDS Client on Windows 7 Pro remotely.  The issue is when I attempt to connect via the RD Web Access and click the published desktop I want to connect to I am seeing that the "gateway" and "remote computer" are listed as the same name "gateway.company.com".

The settings should be:

Remote Computer - rds1.company.com
Gateway - gateway.company.com

How can I get the correct remote computer name in the published desktop connection on RDweb?

One thing that I can not change is the fact that when I inherited the client their AD and external domain name are the same.
crystalinkAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cliff GaliherCommented:
It sounds like the published remote desktop in the session collection is simply configured wrong. The rep file is automatically generated from those settings.
0
crystalinkAuthor Commented:
I deleted it and recreated the published desktop and the session host is set correctly.  I'm not seeing anywhere else to make a change in the session settings.
0
MaheshArchitectCommented:
When you connect thrugh rd web access to RD Session host servers \ remote apps, the remote computer must be your RD connection broker and it will take care of providing you RD session host server
You RD Session host server will not come in picture directly

Have you installed RD gateway on same server as connection broker ?
If not Gateway server name and RD Connection broker name must be different
Ensure that your RD gateway server is publishhed on internet and tcp 443 is allowed from internet
Also RD gateway certificate must match to RD Gateway external FQDN
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

crystalinkAuthor Commented:
If I manually plug in the information into RDS client the system works perfect.  The issue is that the RDweb published session has the incorrect information in it and I can not find where that information can be changed in any of the settings.

Yes. I have the RD gateway on the same server as the connection broker.  The RD gateway is published and works fine with the stand-alone client, just not through the web access page.

I have a purchased 3rd party SSL cert.  It is correct.
0
crystalinkAuthor Commented:
Here is what the RDweb connection details are providing.
connection-info.png
0
crystalinkAuthor Commented:
I got it to work.  There was a setting in the RD Gateway Manager RAP Policy that needed to be set to allow access to all network resources.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
crystalinkAuthor Commented:
I figured this out from another website.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.