Internet Explorer 9: Choose to 'Always Allow Installs from XYZ'; Need to Reverse

I am using Internet Explorer 9.  I was getting a pop-up before a plug-in(?) was installed on my system in the Notification Bar.  On the prompt, there was an option for 'More Options'.  I chose this, and it had several options, on of which was 'Always Allow Installs from XYZ'.  Unfortunately, I decided to choose this.  

The Notification Bar no longer prompts, but the installation from this developer is problematic and cannot successfully finish.  So each time it starts, I go down a path that cannot be finished.  I should have chose 'Never Allow Installs from XYZ'.

Can anyone tell me how to change this behavior?  I did go into the options for Internet Explorer, and on the Security tab I made some changes, but A) None of my changes successfully corrected the behavior B) I did not see anywhere that this developer was explicitly specified.

Thanks In Advance for reading my question and whatever time that is put into it.

- Michael
mjs082969Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jcimarronCommented:
mjs082969--
Try a System Restore to a time before you clicked that popup message.
0
nobusCommented:
did you reset  the internet optiosn?   Go to   tools>options >advanced> reset
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mjs082969Author Commented:
Doing a System Restore is not an option.

I did try to reset the Internet Options (and several of the Advanced Options) but was not successfully in reversing this.  I was hoping that someone would be able to tell me where this setting or choice is actually stored.  I imagine this may be someplace in the registry....
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

jcimarronCommented:
mjs082969--
I understand you have allowed installs from XYZ but in fact the installs are not succeeding.  It is not clear whether you want installs from XYZ or not.  Please tell us that.  
"Can anyone tell me how to change this behavior? "  Which behavior?
It might also help if we knew what XYZ is.  Is XYZ listed in Control Panel|Programs and Features?  You have not told us what version of Windows you are using.  
Have you scanned with antivirus and antimalware programs?
Have you Searched in the Registry for references to XYZ?
Did you make any backups prior to all this happening?
0
mjs082969Author Commented:
I am using Windows 7.  

We can rebuild the system if necessary, but was hoping that this would be easier to fix than restoring a backup.

I had not canned with antvirus and antimalware, but have now.  There were no issues identified.

We do not want to allow installs from this company.    We have previously chosen 'Always Allow Installs from XYZ', but do not want to do this any longer as it results in an error.  We have spoken to them and there seems to be a problem or a missing component.

XYZ is not a standard application.  They are a smaller software vendor and I am apprehensive about releasing their name here.  There is no option for choosing XYZ from the Programs and Features Control Panel applet.

I did not scan the registry for reference to XYZ.
0
jcimarronCommented:
mjs082969--
Assuming you no longer wish to access the XYZ site, put the URL for that site into your HOSTS file.  Now that site will be blocked from accessing your PC.
http://www.mvps.org/winhelp2002/hosts.htm
0
jcimarronCommented:
mjs082969--
Earlier you told us a reset did not help.  Has that changed?
0
nobusCommented:
thanks; i suppose it worked - but as jcimarron said a bit info could be useful here?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.