Issue trunking vlan's from one sg200 switch to another.

I am still learning vlans. I have the concept down and was overjoyed when I thought I understood it enough to use it.

Using a single switch I can create 2 vlans (10&200), separate the traffic and everything is good. When I try to "trunk" those vlan's to another switch things break down. These are cisco Sg200 switches.

On switch 2 (SW2) we have port 2 going to a unifi access point. Switch 2 port 1 goes to switch 1 port 4. Switch 1 port 1 goes to router that provides dhcp & routing for the vlans. It looks like this;

[ap] eth1----eth2 [SW2] eth1-----eth4 [SW1] eth1---eth2 [router] eth1----[modem]

I think the issue may be tagging, but when it doesnt work using wireshark doesnt help.

The vlans exist on both switches. On SW2 ports 1&2 are trunk ports tagged 10&200. On SW1 ports 8 & 4 &1 are trunk ports tagged 10&200. If I move the AP to SW1 eth8, things works like they should. SSID 2 &3 use vlan 10&200 respectively. When i move the AP to SW2 eth2 it doesn't work.

I thought trunk ports carried the vlans from switch to switch. I thought the interfaces had to be tagged so the next switch would know what vlan to put them in. Apparently i have something wrong since it doesn't work properly.

Where have i gone wrong?
kassant7Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JustInCaseCommented:
What is your setting for trunk mode?
Maybe both sides are in dynamic auto.

switchport mode dynamic auto
– This command makes the interface willing to convert the link to a trunk link if the neighboring interface is set to trunk or desirable mode. Otherwise, the link will become a non-trunking link.

more about trunking:
https://learningnetwork.cisco.com/servlet/JiveServlet/previewBody/14792-102-1-57313/Dynamic%20Trunking%20Protocol.PDF

Can you paste configuration of switches here?
0
kassant7Author Commented:
How do I get configuration of switch to paste?

Looks like by default, all the ports are in trunk mode. I can switch to general or access, but they all say trunk.
0
JustInCaseCommented:
Usually you can in terminal window select code and copy with ctrl + C, after copying you can paste code to notepad or any other text editor.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

kassant7Author Commented:
I have never use the terminal window. I use the web interface.

How do i access via terminal window and get the settings for you?
0
JustInCaseCommented:
Forget about web interface if you are learning Cisco.

1. You need rollover cable (console cable) -connect it to console port
console-cable.gif2. Terminal software (PuTTy, Tera Term, or some other)
3. Set config for terminal sotware:
   9600 baud
 
8 data bits
   
No parity
   
1 stop bit
4. start typing commands

in this case you need just two:
enable (to enter privileged mode)
show running config

then you can copy paste your switch config (both switches)
:)
0
kassant7Author Commented:
I have one of those cables, but no console port on the switch. Just eth1-8.

Cant we use putty and ssh to the Ip address, or telnet? It's 2014, surely we have more capabilities than a serial connection.
0
JustInCaseCommented:
Sure we can use telnet or ssh.

But usually when you buy new cisco equipment device don't have ip address so you can't access device on any way except serial link :)

Maybe you have one of those devices with only web interface, but you can give device IP address and allow telnet and set telnet password so you can try login into device.
0
kassant7Author Commented:
They already have IP addresses. They are static and I can access the web GUIm which is what ive been using to modify the vlans.

What is the next step?
0
JustInCaseCommented:
enable telnet on switch
get putty set ip address of switch and choose telnet :port 23
and click open

if device have command line enabled - device will ask you for password
0
kassant7Author Commented:
no telnet/cli on this sg200.
0
JustInCaseCommented:
OK.
What should be next?

If I can't see configuration...hm...
You said that VLAN 10 and 200 are allowed on trunk.
ADD native VLAN to trunk. DOT1Q trunking can have problem on some switches if native VLAN is not allowed.
0
kassant7Author Commented:
I can take screen shots!

vlan1 is also allowed on the trunk ports. I will take a SC.
0
JustInCaseCommented:
ok
0
kassant7Author Commented:
Default settings
0
kassant7Author Commented:
Default settings with pic
sg200-117-w.jpg
0
JustInCaseCommented:
That picture means nothing to me.

I can only see that ports are set as Trunk, native VLAN is 1, and that there is ingress filter on trunk.
You have already told me that you set ports as trunk.  And if that is only think to set everything should work OK.
By default between two switches you should use crossover cable, but every modern switch has auto sensing on port so that either should not be a problem.

Lats try to make it simple:
Check are all vlans allowed on trunks (to eliminate problem with filtering VLAN-s)
try to remove ingress filter (same reason as above)

create needed VLAN-s on both switches
0
kassant7Author Commented:
where do i check are all vlans allowed on trunks?
both vlans are created on both switches
0
kassant7Author Commented:
On switch 1, the AP is on port 8. I set the port to general and turned ingress filter off. I didn't see where you could turn the filter off any other way.

The vlan on the AP works. I didnt have to tag the interface or do anything else except turn the ingress filter off.

On switch 2, the AP is on port 2. I turned the ingress filter off for that port as well. SW2 is connected to SW1 on port 4. The vlan on the AP doesnt work.

If i turn the ingress filter off on port4, what issues do we run into with the rest of the traffic coming from SW2?
0
kassant7Author Commented:
I thought id give an update. We got it working.

On the final switch(es) the ports had to be set as access with ingress filtering off. We also have to change the port vlan to TP instead of UP to make it work properly.

Thanks for everyone's help!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kassant7Author Commented:
Worked well after figuring out port settings.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Network Architecture

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.