Dns error

hi,

in my windows server 2012 r2 domain controller when i try to run nslookup its showing below error
Untitled.jpg
Qutub ParawalaIT-SupportAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Qutub ParawalaIT-SupportAuthor Commented:
also when try to run nslookup with my domain ip its showing below error.

2.jpg
0
Qutub ParawalaIT-SupportAuthor Commented:
please advise me is there any dns configuration issue please let me know.
0
AnthonyHamonCommented:
Have you installed DNS on the Domain Controller or is it installed elsewhere?

Check the following
Run ipconfig /all to validate that 'DNS Server' settings are correct.  If not, correct them and retry
Validate that the DNS service is up and running
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

Qutub ParawalaIT-SupportAuthor Commented:
settings are all correct showing please check the below settings

Microsoft Windows [Version 6.3.9600]
(c) 2013 Microsoft Corporation. All rights reserved.

C:\Users\Administrator>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : SRV
   Primary Dns Suffix  . . . . . . . : TestDC.com
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : TestDC.com

Ethernet adapter Ethernet2:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) 82574L Gigabit Network Connectio
n #3
   Physical Address. . . . . . . . . : 00-0C-29-97-5C-C5
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::606e:4ee5:21f4:69e9%15(Preferred)
   IPv4 Address. . . . . . . . . . . : 172.16.17.10(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 452987945
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1B-8A-BF-33-00-0C-29-97-5C-B1

   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Ethernet0:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) 82574L Gigabit Network Connectio
n
   Physical Address. . . . . . . . . : 00-0C-29-97-5C-B1
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::edc9:6e33:cfd4:deca%12(Preferred)
   IPv4 Address. . . . . . . . . . . : 10.211.55.10(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 10.211.55.1
   DHCPv6 IAID . . . . . . . . . . . : 301993001
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1B-8A-BF-33-00-0C-29-97-5C-B1

   DNS Servers . . . . . . . . . . . : ::1
                                       127.0.0.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{3C3784F0-E2D6-47E3-9994-019A788833DA}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{A87C03E9-A7AD-4C70-81A0-4AB8B085EB2D}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes


> ^C
C:\Users\Administrator>
0
AnthonyHamonCommented:
When you launch nslookup, it retrieves the IP address of primary DNS server that the computer is configured to use and performs a  reverse DNS lookup on that IP address.  If reverse DNS zones are not set up then you get the message "Default Server: UnKnown".  

So this message simply means that there is no reverse DNS name for the IP address, which may not be a problem at all.  See the following article for more information:
http://technet.microsoft.com/en-us/library/cc961414.aspx
0
arnoldCommented:
The issue deals with the connection being made to an IPv6 local ip.

Do you have the ipv6 zone :::1 defined.

The other option only use the 127.0.0.1 as the configured DNS server

you would still need to make sure you have the 127.0.0.1 record in reverse dnS.
0
awawadaCommented:
As mentioned you must configure the reverse DNS. Then run the following command in the command prompt as an administrator:

ipconfig /registerdns

also have a look here:
http://technet.microsoft.com/en-us/library/cc780467%28v=ws.10%29.aspx
0
Qutub ParawalaIT-SupportAuthor Commented:
i already create reverse lookup zone and run the ipconfig /registerdns
but still issue is same
0
Qutub ParawalaIT-SupportAuthor Commented:
127.0.0.1 record in reverse dnS is not showing in my reverse zone how can i add this
0
Qutub ParawalaIT-SupportAuthor Commented:
please check this is my reverse lookup zone below and one more thing in my domain dns ip is 127.0.0.1 and i creat reverse
lookup zone with 10.211.55 network id please check below screen shot of my reverse lookup zone and also check my forward lookup zone entry which i also send below
4.jpg3.jpg
0
arnoldCommented:
You need to add a reverse zone 0.0.127.in-addr.arpa
Then add a PTR record for 1 with the name localhost
0
Qutub ParawalaIT-SupportAuthor Commented:
i did all this things but still issue same please check below after adding new reverse zone

5.jpg
0
CaptainMidnightCommented:
The most obvious, immediate reason that nslookup is failing is because Ethernet 2 has DNS servers defined in its adapter properties. The real problem is that you are asking the server to route server roles between two subnets. But in general, DNS and several other server roles are not supported by Microsoft on a dual-homed machine.

I'm assuming that you want to use the 172.16.17.0 subnet to perform backups so as to not put undue traffic on the 10.211.55.0 subnet. If you absolutely must use two NICs on a DNS server connected to two different subnets, DO NOT configure DNS servers on your 172.16.17.10  adapter and carefully configure the binding order of the adapters. In addition, if you are not actually using IPv6, disable it on both adapters.

Read the article below to see the hoops you will have to jump through to accomplish what you want to do and you will probably conclude that using an external, physical router to route traffic from the 172.16.17.0 subnet to the 10.211.55.0 subnet is preferable to dual-homing the server. If you are concerned about excessive traffic on the 10.211.55.10 adapter, team the two adapters on the server on that one subnet instead.

http://networkadminkb.com/KB/a14/multihoming-a-windows-server.aspx
0
Qutub ParawalaIT-SupportAuthor Commented:
so in this case what should i have to do remove one nic card ? or what please advise i already disabled one nic card
which having a 172.16.17.10 ip address
0
Qutub ParawalaIT-SupportAuthor Commented:
now after disabled the ipv6 on both nic card when i try to do nslookup its resolving with dns please see the below snapshot  is tit ok my dns is working fine or not please advise.

6.jpg
0
arnoldCommented:
The record in 0.0.127.in-addr.arpa should be
1in ptr localhost
0
Qutub ParawalaIT-SupportAuthor Commented:
what is the meaning of The record in 0.0.127.in-addr.arpa should be
1in ptr SRV.addomain.suffix ?
in this case what i have to do ?
0
Qutub ParawalaIT-SupportAuthor Commented:
please advise me ?
0
arnoldCommented:
You should not be disabling IPv6 as some services/components on the 2008 and newer version rely on and could have adverse/unexpected behavior

You created the reverse zone for 127.0.0 which is reflected as 0.0.127.in-addr.arpa
In that zone, you created an entry
127.0.0.1 which is incorrect since it make the record look as
127.0.0.1.0.0.127.in-addr.arpa
the record should be/look like
1 IN PTR localhost.

Adjusting the dns/name server entries to reflect 127.0.0.1 and the IP of this server might be a better way.
i.e.
127.0.0.1
10.211.55.10

on the ipv6 side:
Try fe80::edc9:6e33:cfd4:deca instead of fec0:0:0:ffff::1
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Qutub ParawalaIT-SupportAuthor Commented:
Thanks for help i delete all my reverse lookup zone and
After i put my dns ip 10.211.55.10 instead of 127.0.0.1 and then create new reverse lookup zone its now working fine. nslookup resolving server name and ip. also i ddnt remove the ipv6.


Thanks for all for help.
0
Qutub ParawalaIT-SupportAuthor Commented:
thanks for given advise
0
CaptainMidnightCommented:
@Qutub Parawala

I'm sorry to say that your server is still misconfigured. Having a reverse lookup zone of 0.0.127.in-addr.arpa does nothing. The IP stack resolves 127.x.x.x to localhost internally, so the DNS service never sees the request and does not resolve it.

When you connect a workstation to the this server and you cannot do a reverse lookup on 10.211.55.10 from the workstation, please open a new question and you will get advice on how to properly set up reverse DNS zones on a Windows server.


TL;DR:

Make sure you understand and follow the article that arnold mentiond:
http://technet.microsoft.com/en-us/library/cc780467%28v=ws.10%29.aspx.

Disabling the card with 172.16.17.10 address made nslookup work (the dual cards and subnets 'confused' the server).

Putting 127.0.0.0.1 and 10.211.55.10 in the NIC DNS properties is the correct configuration.

Lacking a reverse zone for the server's 10.211.55.0 subnet provides no reverse DNS for that subnet.

Having a reverse zone for any 127.x.x.x subnet does nothing and is a wrong configuration.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.