ldb: module mismatch in ../source4/dsdb/sambd/lib_midules/acl.c

I went to run samba-tool on my Slackware 14.1, 86_64 system and got the following errors:
$ samba-tool user list
ldb: module version mismatch in ../source4/dsdb/samdb/ldb_modules/acl.c : ldb_version=1.1.16 module_version=1.1.17
ldb: failed to initialise module /usr/lib64/ldb/acl.so : Unavailable
ldb: WARNING: Module [samba_secrets] not found - do you need to set LDB_MODULES_PATH?
ldb: Unable to load modules for /etc/samba/private/secrets.ldb: (null)
WARNING: Module [samba_dsdb] not found - do you need to set LDB_MODULES_PATH?
Unable to load modules for tdb:///etc/samba/private/sam.ldb: (null)
ERROR(ldb): uncaught exception - None
  File "/usr/lib64/python2.7/site-packages/samba/netcmd/__init__.py", line 175, in _run
    return self.run(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/samba/netcmd/user.py", line 265, in run
    credentials=creds, lp=lp)
  File "/usr/lib64/python2.7/site-packages/samba/samdb.py", line 56, in __init__
    options=options)
  File "/usr/lib64/python2.7/site-packages/samba/__init__.py", line 114, in __init__
    self.connect(url, flags, options)
  File "/usr/lib64/python2.7/site-packages/samba/samdb.py", line 71, in connect
    options=options)

Open in new window

The first error says, "ldb_version=1.1.16 module_version=1.1.17" This used to work and I recently updated my OS with:
$ slackpkg update
$ slackpkg upgrade-all

Open in new window

I assume therefore that ldb didn't get updated. How can I fix this? I've looked for an ldb package but can't seem to find anything on that. I probably shouldn't have updated in the first place.
LVL 1
jmarkfoleyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SandyCommented:
is it possible to uninstall and re-install the pkgs once again ?

TY/SA
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jmarkfoleyAuthor Commented:
How would I do that? I haven't actually installed any specific packages myself. All I did was `slackpkg update` and `slackpkg upgrade-all`. I've not often used installpkg. I usually configure/make/install by-hand.
0
gheistCommented:
That is the source of problem. Slackware packages will not install correctly unless you remove your handmade packages.
0
jmarkfoleyAuthor Commented:
I solved this by re-installing from scratch, then immediately doing the update. Everything worked fine then.

I supposed things built before doing an upgrade don't necessary work. So, I'll just not do any more upgrades until I'm ready to rebuild everything -- probably when I go to the next distro release.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.