Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

How to configure Cisco SGE 2000 Switch with same configurations as HP ProCurve 2510 Switch

Posted on 2014-08-25
4
Medium Priority
?
1,095 Views
Last Modified: 2014-09-06
Hi,

I currently have an HP ProCurve 2510 (24 Ports) Switch already configured on my network.  It's connecting to my SonicWALL TZ215 (router and firewall) with all the VLAN's configured and working properly.  I'm trying to mimic the configurations of the HP ProCurve with my Cisco SGE 2000 (24 Ports) Switch.  The HP ProCurve Switch is soon going to be replaced with the Cisco SGE Switch.  I'm not that familiar with changing the configurations through command line but if I have to I can try.  I'm use to doing everything through the GUI especially on the HP ProCurve switches since they make it so easy.  But again, if I have to make the changes through the command interface for the Cisco SGE 2000 Switch I can try.

HP ProCurve Configurations:

---------------------------------------------------------------------------------------------------------------

; J9279A Configuration Editor; Created on release #Y.11.44

hostname "ProCurve 2510G-24 - A"
ip default-gateway 10.5.1.254
snmp-server community "public" Unrestricted
vlan 1
   name "DEFAULT_VLAN"
   no ip address
   no untagged 1-24
   exit
vlan 5
   name "Internet"
   untagged 1
   ip address 10.5.1.193 255.255.255.0
   jumbo
   exit
vlan 103
   name "iSCSi-103"
   untagged 20-24
   no ip address
   tagged 1,14-19
   jumbo
   exit
vlan 102
   name "vMotion-102"
   no ip address
   tagged 1,8-13
   jumbo
   exit
vlan 104
   name "VM-MGMT-104"
   no ip address
   tagged 1-7
   jumbo
   exit
spanning-tree
spanning-tree force-version RSTP-operation

---------------------------------------------------------------------------------------------------------------

Please let me know of how I can go about this.  As you can see from the HP ProCurve Switch Configurations, it's very simple and easy to understand.  I know that the commands for Cisco are a little different than the HP ProCurve terminology.  So when giving your suggestions please describe what the commands are doing, replacing, etc...so I can see the comparison.

Any help would be greatly appreciated.

Thanks
0
Comment
Question by:Lumious
  • 3
4 Comments
 
LVL 20

Accepted Solution

by:
rauenpc earned 2000 total points
ID: 40283100
I'm not sure if the SGE 2000's command line is the same as normal Cisco IOS, but if it is the same as IOS, here are a few commands.

!create layer 2 vlans
vlan 5,102-104

!enable jumbo frames
system mtu jumbo 9000

!if a port is a simple access port with one untagged vlan
interface gig0/1
switchport access vlan 102
switchport mode access

!if a port needs to have tagged vlans
interface gig0/1
switchport trunk encapsulation dot1q (this command may or may not exist so if it error's at this command don't worry)
switchport mode trunk
!optional commands
!specify untagged vlan
switchport trunk native vlan 102
!specify which vlans are to be allowed (must include the native vlan to allow the native vlan)
switchport trunk all vlan 5,102,104


You would end up with a configuration similar to

interface gig0/1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 5
switchport trunk allowed vlan 5,102-104

interface range gig0/2 - 7
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 104

interface range gig0/8 - 13
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 102

interface range gig0/14 - 19
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 103

interface range gig0/20 - 24
switchport mode access
switchport access vlan 103


spanning tree mode rapid
0
 

Author Comment

by:Lumious
ID: 40293645
Hi,

Been busy all week...Will try to configure the switch this weekend.

Will get back as soon as I can.

Thanks
0
 

Author Comment

by:Lumious
ID: 40305570
Hi,

Just got around to configuring the switch from your suggestions.  I believe everything has been configured correctly on the Cisco switch, just like how it was for the HP ProCurve switch.

Thank you so much for assisting.

My next goal is to configure another switch just like this Cisco SGE2000 switch so that I can have stacking enabled for redundancy.  I have another Cisco SGE2000 switch that I'm going to use.

I will be posting another question shortly in regards to this and will provide the link here if anyone is able to assist.

Thanks
0
 

Author Comment

by:Lumious
ID: 40307596
Hi,

As promised, here's the link to my next question.

http://www.experts-exchange.com/Security/Software_Firewalls/Cisco_PIX_Firewall/Q_28512839.html

Any assistance would be greatly appreciated.

Thanks
0

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

During and after that shift to cloud, one area that still poses a struggle for many organizations is what to do with their department file shares.
There’s a movement in Information Technology (IT), and while it’s hard to define, it is gaining momentum. Some call it “stream-lined IT;” others call it “thin-model IT.”
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Suggested Courses

581 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question