Laptop Doesn't Recognize the Battery

Gateway laptop with Windows 7. Everything seems to work except it will not recognize the battery. I purchased a new battery but no luck. I deleted the battery from device manager and let Windows reinstall but no luck. I have cleaned the contacts and made sure the connections are good but no change. Any suggestion on getting this laptop to see and charge the battery?

Thank you!

Robert
Robert EhingerIT specialistAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Priya SudharsanProgrammer AnalystCommented:
Do not remove the Battery from device manager.

Just Disable, wait for 3 minutes and Enable again. Let me know of its not working.
Robert EhingerIT specialistAuthor Commented:
OK, I disabled and waited and after enabling again it said "Plugged in not charging." When I returned to the computer later I was back to the original problem of the battery not being recognized.
nobusCommented:
is it an original battery?
if not, it may just not work ok with others (i had the case - tried 2x battery from 3rd party- never worked!)
can you locate such a battery for testing? because it also may come from the motherboard charging circuits
Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

Robert EhingerIT specialistAuthor Commented:
Same issue with an original and replacement battery.
nobusCommented:
then i must say the circuits probably are damaged
the only other possible solution i see is upgrading the bios
Robert EhingerIT specialistAuthor Commented:
The BIOS has been upgraded
nobusCommented:
i found this   http://answers.microsoft.com/en-us/windows/forum/windows_vista-hardware/gateway-laptop-plugged-in-not-charging/6db4fe50-d318-44da-a938-2fc58f4bbe7b
Under the Batteries category, right-click the Microsoft ACPI Compliant Control Method Battery listing, and select Disable

i hope it helps..

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Laptops Notebooks

From novice to tech pro — start learning today.