How to configure Exchange 2010 in DAG with iSCSI storage

Hello,

We purchased EMC NAS, I configured it as iSCSI storage used iSCSI initiator to configure it in my Exchange database server. One NIC interface on Exchange and NAS are facing the Network. Second NIC on both Exchange and NAS are isolated and only talking to each other (separate LAN). I was told that even if they communicate on separate networks I need to tell Exschange in DAG not to talk to NAS thru Network interface and having a hard time using the command in the shell. Just to be more specific, here are actual names of my devices
Exchange database server      RT-MBX5
DAG                                              DAG1
Storage (NAS)                             iqn.2012-07.com.lenovoemc.px4-300r-thybld.exchdatabases
Your input will be greatly appreciated.
Thank you in advance,

sw
swolff1ITAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jamie McKillopIT ManagerCommented:
Hello,

What you are referring to is using a separate MAPI and Replication network. This has nothing to do with iSCSI or your SAN. Ideally, you have one NIC dedicated to MAPI (client connectivity, Exchange server communication, etc.) and one NIC dedicated to DAG replication traffic.

If you only have two NICs in your server, I recommend you dedicate one to iSCSI and use the other one as a shared MAPI/Replication network. The reason for this is that you want to ensure you always have enough bandwidth for iSCSI and you don't want your MAPI or replication traffic affecting that. Ideally, you would have three NICs then you could dedicate a NIC to each of iSCSI, MAPI, and Replication.

To set this up in EMC, go to Organization Configuration / Mailbox / Database Availability Groups. For Networks, make sure there is only one network listed. Make sure replication is enabled and make sure only the subnet of the NIC you plan to use for MAPI/Replication is listed.

-JJ
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
swolff1ITAuthor Commented:
Here is my config.
configDAG.docx
2 NICS

IP 10.1.1.100 is NIC that connects iSCSI storage.

Thanks.
0
Jamie McKillopIT ManagerCommented:
If you only have 2 NICs, why am I seeing three networks/subnets?

-JJ
0
swolff1ITAuthor Commented:
Thank you for your reply. This is exactly what I did and NAS works well.
Appreciate your recommendation.

Sig
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.