WES 7 - trust relationship between this workstation and the primary domain failed

I am noticing an issue with my clients which are Win7 Embedded where after a few days after they've already been imaged and joined to the domain and working fine, they end up with the message "The trust relationship between this workstation and the primary domain failed." and have to be re-joined.

It's not happening 30 days which is all I keep reading about online as far as the Computer Password renewal thing.
is there something else I can check?

It's not happening on the full laptop clients, just the Windows 7 embedded thin clients I've been setting up.

They were sysprep'd normally at the time of capture, so I'm not sure what else could be going on to cause them to unjoin the domain.
There is a file-based write filter enabled, but that's for the file-system, not the registry, and I'm not aware of any specific folders that need to be excluded.
garryshapeAsked:
Who is Participating?
 
garryshapeAuthor Commented:
I had to fix my deployment script and adjust a couple of things since these are thin clients that use the File Based Write Filter.

First was to capture the image with the DisablePasswordChange set to 0:

%windir%\System32\reg.exe ADD HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters /v DisablePasswordChange /t REG_DWORD /d 1 /f


Second thing to do was restart the computer after joining the domain with the FBWF off, then enabling the FBWF and adding exlcusions and rebooting afterwards (part of my OSD Task Sequence).
0
 
Prashant GirennavarCommented:
0
 
Adam LeinssServer SpecialistCommented:
Do these computers all have unique computer names?
0
 
garryshapeAuthor Commented:
This solution is what worked for me in my own very unique situation.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.