403 forbidden error on WAMP localhost of Wordpress' stylesheet file bootstrap.css

Hi,

I'm getting a 403 forbidden error on my WAMP localhost (Win 7 64bit) using Wordpress. It can access the index and the Apache server is working fine but it can't access the stylesheet.

I tried this:
<Directory "C:/wamp/www/test/trunk/php/wordpress">
	Options All
	AllowOverride all
	Order Deny,Allow
	  Allow from 127.0.0.1
</Directory>

Open in new window


And I tried the same above code except with "Allow from all" but to no avail.

Note - Apache can access the main style.css of the active theme folder but it can't access the @import bootstrap.css files. For some reason, it's trying to access the .css file as an html file it seems like.

Here's the snapshot of the Network tab in the Chrome dev tool:Chrome dev tool Network tab. bootstrap.css has a 403 forbidden error
Here's the Chrome dev snapshot attached.
Victor KimuraSEO, Web DeveloperAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mandeep SinghDatabase AdministratorCommented:
Hi,

Try to open your bootstrap.css file location in a new tab. like: http://localhost/........./bootstrap.css

Check permission of bootstrap.css file.
0
Victor KimuraSEO, Web DeveloperAuthor Commented:
@Mandeep Singh,

yes, it's a permissions error. Odd that when I unzipped the bootstrap zip folder all the folders (css, fonts, js folders) are greyed out. I looked for the permissions but I don't see anything that is causing the "greyed out" permissions. On Windows 7 64bit pro.

greyed out bootstrap download files. How do I ungrey them (set the proper permissions)?
---

Oh, I think I just figured it out. Why does Bootstrap have the setting of "file encryption" on their download files. That is so odd and doesn't really make sense to me.

Solution: right click folder, click "Properties", then "Advanced" button, then uncheck "Encrypt contents to secure data". That does the trick. Spent over an hour trying to figure this out but by the Father's grace figured it out.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Victor KimuraSEO, Web DeveloperAuthor Commented:
I think I found the answer on a "hidden" blog post somewhere or some forum.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.