Mapped Network drive - "The target account name is incorrect"

Hi,

I have a strange issue, that i cant seem to find a fix for it.

i demoted one of the old server and setup a new server with a new name e.g server2 the old name of the old server was server1.

beacsue its a file server and users already have drive mapped under the old server name, i created a Alias CName and pointed server1 to server2. This works fine for all OS except when i try to map a drive on 2003 server e.g \\server1\drive it throws that error?

note- if i map it with a new name \\server2\drive on server 2003 it works! (so its the Alias CName that it dont like?)

im sure there is some sort of registry edit i need to edit on server 2003 wich should fix this issue?

please help?

Thanks
badabing1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Chad FranksSenior System EngineerCommented:
on the windows 2003 server try flushing your DNS cache.

ipconfig /flushdns
0
TropicalBoundCommented:
0
bas2754Commented:
For this to work, I believe you need to:

1. Demote the original server (if it was a domain controller)
2. Change the original server to be in a workgroup (if old server is still online)
3. Delete the original server from Active Directory (do this even if step 2 could not be completed)
4. Ensure there are no additional DNS entries in the system for the old server1 other than the alias you created.

My guess is that there is still a server named server1 in Active Directory.  This happened to us a few times when a tech forgets to delete the old server account.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
hairangCommented:
Hi

Try this

    Edit the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters and add a value OptionalNames of type Multi-String
    Add in a newline delimited list of names that should be registered under the NetBIOS browse entries
        Names should match NetBIOS conventions (i.e. not FQDN, just hostname)

and restart the fileserver
0
badabing1Author Commented:
excellent!

worked like a dream, there was the old server1 acocunt in AD, which i disabled and it worked - so i didnt have to delete it but i will later!

Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.