Avatar of Patrick Byrne
Patrick Byrne
 asked on

Installing OS on Poweredge 2800 Raid 1

I am trying to install an OS, any OS on my old Poweredge 2800 while a Raid 1 is configured and it simply wont let me.

i've tried just about everything and get error messages each time. I was able to install an OS on this machine while it was configured for JUST SCSI with one drive in.

Any ideas or help would be appreciated. Thanks everyone.
Server HardwareMicrosoft Legacy OS

Avatar of undefined
Last Comment
Patrick Byrne

8/22/2022 - Mon
Chad Franks

what errors are you getting?
Patrick Byrne

ASKER
this error was the most recent one.

http://support.microsoft.com/kb/2476568

other errors have been when the OS install just stops copying and freezes, it also has complained about not being able to copy certain files during the OS install.

My most recent glitch is when i load Windows 7, the set up cannot see my hard drives. two SCSI hard drives in there set up as Raid 1.
ASKER CERTIFIED SOLUTION
PowerEdgeTech

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
Patrick Byrne

ASKER
Thanks. how do i install these drivers WITHOUT being able to get the OS install? are there instructions on how to install through the BIOS? thanks again.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
PowerEdgeTech

Download and run the EXE on any Windows computer to extract the files, then copy them to a USB flash drive, then browse to them after clicking on the Load Driver link during the install when Windows says it can't find any drives.
Patrick Byrne

ASKER
I copied the files to a flash drive and browsed to them in the windows installation.

it gives me a "No device drivers were found. Make sure that the installation media contains correct drivers, then click OK."
rindi

Or boot the server from the OpenManage CD or DVD that came with the server, it then helps prepare it and asks you to select the OS you want to install from a list. When it is ready the CD/DVD will pop out and you will be asked to insert your OS DVD. You then won't have to provide the drivers during the installation. If you lost the CD, you can download it from the Dell support site.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
PowerEdgeTech

Windows 7 is not a supported OS on any Dell server, so the OpenManage utilities won't work.

What is the firmware version of your PERC 4e/Di?  Minimum supported FW version for 2008R2 drivers is 5B2D.
Patrick Byrne

ASKER
How can i find out the Firmware version of my PERC 4e/Di?

i was able to load the drivers from a floppy drive, it found the hard drive, then gave me the following error message.

"Windows Cannot install the required files. Make sure all files required for installation are available, and restart the installation. Error code: 0x8007045D"
SOLUTION
PowerEdgeTech

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Patrick Byrne

ASKER
FW-Version---Copy.jpeg
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
PowerEdgeTech

516A is really old.  You will need to update your PERC firmware (BIOS and ESM first) to use the driver and install the OS.
Patrick Byrne

ASKER
okay. is there a step by step for that? thanks in advance for your help.
SOLUTION
PowerEdgeTech

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Patrick Byrne

ASKER
i used the floppy driver from this site and it updated for me.

http://www.dell.com/support/home/us/en/04/Drivers/DriversDetails?driverid=NPGKX

the firmware version is now 522A. i'm currently trying to install windows server 2008 and it appears to have stalled at expanding files.

is there anything else i'm missing?
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Patrick Byrne

ASKER
just got this error message again,

error2.jpeg
SOLUTION
PowerEdgeTech

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Patrick Byrne

ASKER
okay. forgive my ignorance, but how can i go about updating the BIOS and ESM?
SOLUTION
PowerEdgeTech

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
rindi

Also, if you have problems during the files extraction, this is often due to either a bad DVD or DVD drive. Try installing the OS not via optical drive, but rather via a USB stick.
Your help has saved me hundreds of hours of internet surfing.
fblack61
Patrick Byrne

ASKER
i dont think that the drive is bad or the dvd is bad. I have been able to install Windows on these hard drives using the media and cd/dvd drive when the machine was set to just SCSI enabled.

this is the most recent error message i got even after updating the BIOS, PERC 4e/Di and ESM firmware.

http://support.microsoft.com/kb/2476568
PowerEdgeTech

So, the PERC is now up to date?  If so, did you follow the steps in the article you posted, deleting ALL existing partitions?  If so, you might try partitioning/formatting the disk from the repair command prompt (diskpart).
Patrick Byrne

ASKER
Yes. Current PERC is V.5B2D. I didnt see that part of the article. I am currently clearing both physical drives in the CTRL+M utility.

after this, should i try partitioning/formatting the disk from the repair command prompt? how do i access the repair command prompt.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
PowerEdgeTech

When you "clear" the physical drives, make sure you go to Configure and erase the existing Logical Drives (arrays).  Create a new one, but make sure you Initialize the new LD/VD once you create it.

Try it again, and if it still doesn't work, try partitioning from diskpart.  You access the repair command prompt by clicking the Repair Your Computer link (bottom-left corner) instead of the Install Now button.
Patrick Byrne

ASKER
Same error message. when i ran DISKPART, it couldnt find the OS partition so i couldnt format it that way.

i'm trying to install one more time on a USB key, not sure what else i can try here. any other ideas? i appreciate the time you have put into this with me today.
PowerEdgeTech

I've never tried installed Windows 7 on a 28x0, but I have installed 2008R2 on dozens of them.  All I can guess is that there may be an incompatibility with the 2008R2 driver on Windows 7.
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
Patrick Byrne

ASKER
the failure states I have been having the past few times has been with Server 2008 Standard, not Windows 7. Should I try Server 2008R2 next?

it's almost as if the files are being copied fine at first, then something happens with the RAID 1 that is set up and it gives me that error message.

anything else in the BIOS or CTRL+M menu i can double check?
Patrick Byrne

ASKER
would i still have to load the PERC 4e/Di drivers from the floppy before trying to install the OS?
Patrick Byrne

ASKER
Just tried to switch the RAID from 1 to 0. same problems occurred.

is there something physically i can reseat inside the server like the RAID controller or anything else?
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
SOLUTION
PowerEdgeTech

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Patrick Byrne

ASKER
Yes I initialzed the array after i created it.

I've never used DISKPART before. what command do i run to format the partition in there? i havent tried that yet.
Patrick Byrne

ASKER
I'm now getting a message during boot. "Memory/battery problems were detected. The adapter has recovered, but cached data was lost."


can this be causing my issues?
PowerEdgeTech

I'm now getting a message during boot. "Memory/battery problems were detected. The adapter has recovered, but cached data was lost." can this be causing my issues?
Yes.  Are you getting this on every boot?  If so, is the LCD panel blue or amber and scrolling and error message?  If it happens on every boot and the LCD is blue, then that could explain everything.  It means you need to replace the RAID memory DIMM (4D554), and nothing will work (except disabling RAID altogether) until you do.
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
Patrick Byrne

ASKER
Yes, its now happening on every boot. the LCD panel is amber and not scrolling anything right now.
PowerEdgeTech

If the LCD were scrolling a message about the battery, you would need to replace the battery, and you likely wouldn't be having the memory/battery-related problems (although the memory/battery message may persist).  Since you can't see an error scrolling, then it may or may not be the more serious of the memory/battery issues.  I would start by unplugging the server, hold power down for 10 seconds, remove riser, disconnect RAID battery, reseat RAID memory, reconnect RAID battery, reinsert riser to see if your situation  persists.
Patrick Byrne

ASKER
tried that. same message.

should the cache policy be Direct IO or Cached IO? does that affect anything?
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
PowerEdgeTech

No, it won't have any effect.

You could try booting to an OMSA Live DVD to look at the hardware logs (System, Logs tab, Hardware sub-tab):

http://linux.dell.com/files/openmanage-contributions/omsa-65-live/OMSA65-CentOS6-x86_64-LiveDVD.iso

If it is your RAID DIMM causing the memory/battery message, no OS can be installed, repaired, or run on the drives, leaving you with replacing the DIMM as the only option to repair.  Since you have an amber light, it might be related (battery), or it might not (chassis open or something benign).
Patrick Byrne

ASKER
okay got OMSA Live DVD running. I ran the DSET icon on the desktop. it ran a report and now its asking for a password.

I tried root and linux as the suggested user name and password, that didnt work. any idea what it might be?
PowerEdgeTech

Password:  dell
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
PowerEdgeTech

Also, the application OpenManage Server Administrator (OMSA) should have an icon on the Desktop, with which you can view the logs directly.
Patrick Byrne

ASKER
the only error messages i see in the logs are the ones listed below.

"Redundancy lost Redundancy unit: BMC PS Redundancy Chassis location: Main System Chassis Previous redundancy state was: Unknown"

"Chassis intrusion detected Sensor location: Intrusion Chassis location: Main System Chassis Previous state was: Unknown Chassis intrusion state: Open"

"BMC Intrusion sensor detected an intrusion"

"BMC PS Redundancy sensor redundancy lost"

"PROC Init Err processor sensor transitioned to non-recoverable"

"PROC_2 Status processor sensor IERR"
PowerEdgeTech

Did it have dates for them?  

The intrusion message could be from the lid not being on or not secured.  The PS redundancy message could appear if you have only one PSU plugged into power.  If the PROC messages are current, then that could mean that they are not related to the memory/battery message during POST, and that you have two issues (the PROC issue is not always critical).
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Patrick Byrne

ASKER
the PROC error messages where from a few months ago.

yes, the case is not on and i only have one power supply plugged in.

i think at this point i will have to order a new RAID memory DIMM (4D554) and a Raid battery, right?
PowerEdgeTech

That would be my suggestion.  The logs don't say anything about the RAID battery, so the messages on the LCD would (if they were visible) likely only be for chassis intrusion and/or power supplies.

The memory/battery issue on 8th generation servers is pretty specific to that hardware, and widely misunderstood, even by Dell's Support personnel.
Patrick Byrne

ASKER
okay thank you. i have a spare riser card i am going to try out. if the memory/battery issue is still there, then i know its most likely not the riser card.

i'll post back after i get the new Raid DIMM and Raid Battery and let you know if that worked. thanks so much for your time, paitence and expertise.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
PowerEdgeTech

Swapping the riser would eliminate the DIMM slot as the culprit, but it is almost always the DIMM.  I have only seen the riser (DIMM slot) at fault once.  Getting the battery too is good, just in case, but it probably won't be necessary.  In my experience, if the battery is at fault, the OS functions normally, although performance is degraded because the controller disables write caching.  When the memory is at fault, the system is unusable in RAID mode.

Good luck.
Patrick Byrne

ASKER
yea. just replaced riser, same issue.
Patrick Byrne

ASKER
Hi Poweredge tech. I'm back.

You were right, i replaced the Raid DIMM and Battery, and sure enough was able to install windows. so Thank you so much for your input and expertise.

I have another question for you now.

I have two poweredge 2800s. One that is currently being used and the one I am rebuilding to replace the one being used.

The older one has a Raid 5 in it with 4 300 GB drives. Is it at all possible to swap the 4 drives out of the old server, and place them in the new one i'm building, configure the Raid 5 in the new machine without losing any data? thanks again for all your help.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
PowerEdgeTech

Yes, you can.  As a precaution though, make sure that the "new" one has the same level or newer firmware (BIOS, ESM, PERC).  You can also only "migrate" disks in the same format - RAID vs. SCSI/non-RAID.  As long as both are using the onboard PERC 4e/Di controller, you should be good.

Power off both machines, remove the drives from the "old" one, insert in "new" one, power on, boot to CTRL-M configuration utility for the PERC, Configure, View/Add, choose Disk View, save on exit.
Patrick Byrne

ASKER
Okay I will try that tomorrow. Thanks again.

And the OS versions going from XP to 7, the Raid 5 doesn't care about that, right?
PowerEdgeTech

No, the OS doesn't care that its "disk" is a RAID 5, and the RAID 5 doesn't care what OS is installed on it.
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
Patrick Byrne

ASKER
If i wanted to move the two OS drives from the two slots they are in now, to two other slots WITHOUT losing the OS installed on them, how can that be accomplished in the Raid Config Utility?
PowerEdgeTech

Same way.  It may not even care that they are in different slots - it may just adjust automatically.  (may not if firmware is out of date though)  If it does say there is a foreign configuration or missing disks, then you will need to go to View/Add to import the Disk View configuration.
Patrick Byrne

ASKER
do I have to clear the current configuration before i try that?
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
PowerEdgeTech

No.  It will either 1) tell you that disks are missing and that a new configuration is found, which you would need to import, or 2) it will see the disks in the new slots are the same configuration as the missing disks and simply use them as before in their new locations.
Patrick Byrne

ASKER
Hi Poweredge tech.

i have placed the 4 300 GB drives from the "old" server into the "new" server. i have attached two pictures. one is the "old" configuration showing the two seperate raid channels. the other is a pic of the config in the "new" server. showing the four drives on the same side of my raid 0. how can i move these drives over to Raid Ch-1? thanks.
C--Users-pbyrne-Desktop-image.jpeg
C--Users-pbyrne-Desktop-2image.jpeg
Patrick Byrne

ASKER
C--Users-pbyrne-Desktop-image.jpegC--Users-pbyrne-Desktop-2image.jpeg
Your help has saved me hundreds of hours of internet surfing.
fblack61
PowerEdgeTech

You probably have the daughterboard installed that splits the backplane.  You can remove it, or you can leave it ... having them on different channels isn't going to negatively affect the array.
Patrick Byrne

ASKER
okay. so i can leave the Raid 5 on the same channel as the raid 1 OS, correct? i do i configure these drives now in here to raid 5 without losing anything and screwing up the other raid?
PowerEdgeTech

If you select Disk View and save it, it will only import the configuration that was found to be foreign (Disk vs. NVRAM) and will leave other non-foreign configurations (your existing RAID 1) alone.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Patrick Byrne

ASKER
how do i select disk view in here? forgive my ignorance.
PowerEdgeTech

When you boot into CTRL-M, Configure, View/Add, it should ask you if you want the Disk View or NVRAM View.  You would want to select Disk View in this case, because the disks have the configuration you want to use/import.  If it doesn't ask, then it has automatically imported the configuration (which is fine too).
Patrick Byrne

ASKER
yea it didnt ask me. so it auto imported the config, but the four 300 GB drives say ready. do i put them "online?" or do i just boot to windows and assume the Raid 5 is configured correctly?
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
Patrick Byrne

ASKER
Will putting the four drives "online" wipe the data off of them?
PowerEdgeTech

You can't force online "ready" drives - only "failed" drives.  Even if you could, it would be dangerous in most circumstances.  

If retrying the import doesn't work, the only thing you would be able to do is called a retag - basically reconfiguring your array without initializing it (Fast Init needs to also be disabled before trying this).
PowerEdgeTech

Oh, sorry ... I didn't notice that little significant detail.  It did not import it and it did not recognize the configuration on the disks.  One of two things is likely the reason:  1) the firmware on the target server's controller is older than the source server, or 2) you inadvertently selected to ignore the configuration when the server first booted up or upon entering CTRL-M.  

You can try powering down, removing the disks, power up, then power down, insert the drives, and try it again, making sure to accept any changes presented, and booting to CTRL-M, Configure, View/Add to make sure the configuration is correct.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Patrick Byrne

ASKER
and retrying the import is just going to configure - view/add configuration? yea that brings me to the same screen shot were it shows the 4 300 GB drives in a "ready" state. how do i disable fast init? and how do i attempt a retag?
PowerEdgeTech

and retrying the import is just going to configure - view/add configuration?
AFTER powering down, removing drives as described.  Entering the View/Add menu a thousand times will not change what it sees without removing the drives.  Removing them and attempting to reinsert them is the only way to see if it will see the configuration to import.  You could put them back in the source server to make sure the configuration is still recognized.
Patrick Byrne

ASKER
the firmware on the "new server" is newer than the firmware on the "old server."

i have powered down, removed the drives, powered up, powered down and inserted the drives again.

am i looking to accept any changes BEFORE entering CTRL M? or while in the config utility?
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
PowerEdgeTech

If prompted to accept changes before entering CTRL-M, then accept them.  Depending on what it finds, it may or may not ask before CTRL-M - it may simply tell you to go to CTRL-M, View/Add to sort it out.
Patrick Byrne

ASKER
didnt prompt me to accept any changes before CTRL M. I'm in View/Add again, same symptoms. 4 drives say ready.

at this point i dont care about the data as much, just need to get this server up and running again. how do i config these four drives to be a raid 5 without screwing up the other Raid 1 OS?

unless you can think of anything else, im just going to do that.
Patrick Byrne

ASKER
Auto Rebuild is enabled. could that have screwed us up?
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
PowerEdgeTech

No, auto rebuild would only affect things if a drive had failed.

If you just want to wipe it out and start over, then just go to View/Add, select each drive (Space Bar) and configure a new RAID 5 (Initialize array when done creating).
Patrick Byrne

ASKER
put the drives back in the "old" server. got this message. what do i do to clear that?
Patrick Byrne

ASKER
also, we are thinking it might be easier to move the OS drives from the "new" server to the "old" server. would i have to clear the configuration on the "old" server before trying this?
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
PowerEdgeTech

That pic is what you should have seen on the "new" server.  Going to CTRL-M, Configure, View/Add, you will find the option between Disk and NVRAM.

also, we are thinking it might be easier to move the OS drives from the "new" server to the "old" server. would i have to clear the configuration on the "old" server before trying this?
No, don't "clear" the config.  Moving the drives over should be as I described earlier, but without knowing what caused the last snafu, it's hard to say it won't happen again.  Firmware mismatch (aside from the user pressing the wrong keys) is the most common reason for the import to fail (newer is usually fine, older risks the configuration not being recognized or imported).
Patrick Byrne

ASKER
got the "New" OS drives in, it finally gave me the option for disk view or NVRAM view. which config should i save? i have attached two pictures. NVRAM view seems right to me over disk view? is that accurate? C--Users-pbyrne-Desktop-4image.jpegC--Users-pbyrne-Desktop-5image.jpeg
Patrick Byrne

ASKER
Just as a reminder, we have two OS Raid 1 drives and four Raid 5 data drives.

the disk view is showing two more disks than we physically have in ther server and the NVRAM view is showing exactly what we have. thats what seems to be throwing me off.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
PowerEdgeTech

If you are introducing configured disks to a controller, you ALWAYS want the Disk View, so I would almost without reservation tell you to save the Disk View, but I'm not sure what else you have going on there.  Prior to bringing the disks over, did you create your RAID 5?
PowerEdgeTech

And what slots are all the drives in?  I would only put in your RAID 1 drives at this point.
Patrick Byrne

ASKER
I have the Raid 5 back in its original slots in its original server. i moved the OS drives from the "new" server to the "old" server. i didnt create anything else.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
Patrick Byrne

ASKER
so should i remove the Raid 5, boot, save disk view with new OS drives, see if it boots, then power down, plug raid 5 back in, save disk view again, then boot?
Patrick Byrne

ASKER
and why does the disk view show a completely jacked up config and the NVRAM view shows EXACTLY what is plugged in physically?
PowerEdgeTech

What slots were the RAID 1 drives in on the "new" server, and what slots are they in on the "old" server?  What slots are the RAID 5 drives in on the "old" server?  And when they were in the "new" server?
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Patrick Byrne

ASKER
the raid 1 slots on the "new" server was 2 and 3. in the old server they are in 0 and 1.


the Raid 5 slots in the "old" server are 4, 5, 8 and 9.
Patrick Byrne

ASKER
raid 5 same exact spots in the "new" server.
PowerEdgeTech

Something isn't right.

Was there a RAID 1 (or unconfigured) disks on slots 0,1 on the "old" server before putting in the "new" drives?

The thing I'd worry about with the NVRAM view is that disks 0,1 are referring to the "old" RAID 1 disks, and when they have a different signature than the "new" ones, the controller will say the original RAID 1 is missing and will have already ignored the configuration on the "new" disks, causing disks 0,1 to show as failed or ready.

Is your RAID 5 currently configured and okay on the "old" server?  or did you delete the config?  Was the RAID 5 configured on the "new" server, or where the disks simply installed, unconfigured?
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
Patrick Byrne

ASKER
yes there was an old Raid 1 configured on the "old" server. i put the new OS drives in those slots.

i didnt delete anything. the Raid 5 still gives me that error message about unresolved configuration, only this time, when i go into CTRL M, it doesnt give me the Disk VIew NVRAM view.

the disks on the "new" server where simply plugged into the slots, not configured in CTRL M.
PowerEdgeTech

the disks on the "new" server where simply plugged into the slots, not configured in CTRL M.
Ok, so that is why the Disk view shows your RAID 5 drives as READY - that is part of the overall disk configuration on the "new" server.  The "new" drives were slots 2,3, which is why they show online there.  On the "old" server, they should be on slots 0,1, but that will probably adjust once the configuration is imported (called Drive Roaming).  So, that said, I'd put my money on the Disk view, although there is a chance, from what is shown here, that it will overwrite the configuration currently on the RAID 5 disks, marking them as "ready" instead of online.  A retag could be done at that point, or they could simply be reconfigured, IF they do indeed get changed to ready.
Patrick Byrne

ASKER
so plug the "new drives into the "old server, slot 2 and 3, save disk view, even thought the raid 5 is showing "ready" and not "online" and i should be good?
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Patrick Byrne

ASKER
if you can list the exact steps i have to take here that would be much appreciated. this stuff confuses the crap outta me.
PowerEdgeTech

so plug the "new drives into the "old server, slot 2 and 3, save disk view, even thought the raid 5 is showing "ready" and not "online" and i should be good?
Yes.  The steps:  power off, remove old drives, insert new drives, power on, save Disk view.  I've done this dozens and dozens of times, and that is all there is to it, but you've already seen out-of-the-ordinary behavior.  Worst case, it marks your RAID 5 drives as ready instead of online.
Patrick Byrne

ASKER
does clearing configuration wipe the data of the drives? im running into failed drive slot issues now.
Your help has saved me hundreds of hours of internet surfing.
fblack61
Patrick Byrne

ASKER
PowerEdgeTech

Failed drives you can force online - if you want to try that.  Force only one of them online, and if it works, then rebuild the other.  

Remind me again why you were doing this in the first place?  Is it possible you had a bad drive(s)?  Something is causing these problems - they certainly aren't typical of this procedure.  The controller firmware is out of date, but I'm not sure I would blame it (yet), as I'm pretty sure I've done something at that level.  Are the disks original Dell disks or generic/retail disks?
Patrick Byrne

ASKER
I figured it out, finally. thanks for all your help on this. couldnt have done it without your guidance.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.