Exchange 2010 SSL New Cert Causing Autodiscover Issues

Hello all,
Recently we attempted to move from a wildcard certificate on our Exchange 2010 single server to a digicert SSL certificate. The process seemed easy enough but we found that Autodiscover Outlook clients were getting: "There is a problem with the proxy server's security certificate. The name on the security certificate is invalid or does not match the name of the target site usmail.company.com" and would prompt for credentials. It would never resolve the credentials and continue to prompt, thus never connecting Outlook.
We ensured the cert SANS included autodiscover.company.com as well as all the other to include POP, and IMAP.
What are we missing the server worked fine with the wildcard cert?
Thank you in advance.

kry1972
kryanCAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kryanCAuthor Commented:
Thanks,
Very odd, it appears that the autodiscover URL was never configured when I check in PowerShell. Is this possible since it worked with the wildcard?
0
MAS (MVE)EE Solution GuideCommented:
May be it worked through SCP for internal/domain users
0
David Johnson, CD, MVPOwnerCommented:
autodiscover uses many different urls
Within the domain it first checks active directory
CN=<CAS_SERVER>,CN=Autodiscover,CN=Protocols,CN=<CAS_SERVER>,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=<ORG>,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=example,DC=com

Open in new window


Non domain joined machines do the following:
https://example.com/autodiscover/autodiscover.xml.
https://autodiscover.example.com/autodiscover/autodiscover.xml.
SRV record query where a DNS query for an SRV record is made. The SRV record should be in the format _autodiscover._tcp.example.com, resolving to the FQDN of the Autodiscover endpoint.
https://testconnectivity.microsoft.com Test your settings.
http://www.theemailadmin.com/2013/09/troubleshooting-autodiscover-lookups/
0
kryanCAuthor Commented:
Turns out the auto-discover was never fully configured and went unnoticed because they had been using a wildcard cert that allowed two everything.

thanks

Ryan
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.