Excel 2010 with Sharepoint 3.0 Edit or ReadOnly Prompt

We're running Sharepoint 3.0 on the server and Office 2010 Professional Plus on the workstations.

On all but one workstation, you can navigate the intranet site, click a link for an Excel document, and it brings up a prompt saying "You are about to open.... How would you like to open this file: Read-Only or Edit"

On ONE computer, it does not give this option at all, but instead opens it automatically in Read-Only mode.  The user can then click the Edit Workbook button in the ribbon bar near the top to edit.  The user with the different Excel behavior has the same permissions to the file as everyone else.  He cannot remember to push the Edit Workbook button before he starts editing the workbook, and it apparently causes him to lose work.  We need to fix it, to give him the prompt on how to open the document.   I've searched around Google and haven't found

Here is how it's supposed to look when you press the link:
ExcelPrompt.png
Instead it skips the prompt and goes straight to read-only:
ExcelReadOnly.png
Any suggestions will be greatly appreciated.
vudooxAsked:
Who is Participating?
 
Jamie McAllister MVPSharePoint ConsultantCommented:
I used to see a lot of questions about this, but there wasn't a single cause.

There's this; http://support.microsoft.com/kb/2018958

There's the need to add the Intranet into the trusted zone in IE.

There's a registry hack needed in some cases (but I dont think this is your issue); http://blogs.msdn.com/b/bmatusz/archive/2008/12/10/office-2003-documents-opening-as-read-only-from-moss-2007-document-libraries.aspx

One other question, is Excel 2010 being used by everyone?
0
 
vudooxAuthor Commented:
Yes, the same version of Excel is used across the board.  I'll try your suggestions and let you know if any of that works.  Thanks for the suggestions.
0
 
vudooxAuthor Commented:
The first link to the Microsoft KB, it seems like that might be something to try if all users had this problem, but this is only one user with the problem.  The second link doesn't seem to help either.  There is no HKLM\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\Web Extender Client\ registry hive.  There is Web Server Extensions but no Web Extender Client.

Any more suggestions will be appreciated.  I have a hunch it's an Excel setting on this guy's workstation, but I haven't found that setting yet.
0
 
vudooxAuthor Commented:
You were on the right path with the Trusted Zone.  The site was actually in the trusted zone, but I found that other workstations had it in Local Intranet, so I moved it to that zone for the problem user and it's behaving as desired now.

Thanks for your help!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.