Dell Studio 1737 will not boot

Power LED flashes twice at power on with battery attached or once without it installed. Screen flashes momentarily, then nothing. Tried another AC adapter and battery. Same problem. Removed CMOS battery. No better. Anyone seen this before?
atayqedAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nobusCommented:
here my laptop troubleshooting guide, i hope it helps you :
- remove all external devices
-you can disable devices from BIOS to test (sound, lan, etc..)
- if no display - test with an external monitor
- test if it runs from battery alone, or from AC alone
- test also with a known good battery !
***some laptops have a reset button - if you have one use it!
- remove battery and AC adaptor, hold power button for 20 sec, connect AC and reboot --> any display ? if NO -->
- disconnect all disk and cd drives, battery , and other cards and peripherals, leave only 1 ram stick
- boot -->any display ?
-if you can access the bios battery, remove the battery, AC, and bios battery for a minute to reset the bios
or test it, it should read 3 V
*** you can test the disk on another pc, if you like !

===>>you can test if the mobo works outside the casing, connected to power and external video  !

you can also remove and reseat the video plug - it sometimes comes loose

for troubleshooting the display (LCD) problems : http://www.lcdparts.net/howto/symptom.aspx
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
joinaunionCommented:
Do you have another memory module you can try? Also make sure the one installed is seated correctly.
0
nobusCommented:
atayed - did you find or resolve the mproblem?
please tell us what helped
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Laptops Notebooks

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.