troubleshooting Question

RDC Connection from Win7 to Windows 2012 Server

Avatar of Rob Kinley
Rob Kinley asked on
Remote AccessWindows Server 2012Microsoft Legacy OS
16 Comments1 Solution7052 ViewsLast Modified:

I just started having an issue using Remote Desktop Connection to connect to one of my Windows 2012 R2 servers.  Everything was working fine a week ago, the server has not been rebooted, and no updates have been installed.  Here's what I'm (and all my users) are seeing:

When opening Remote Desktop Connection and connecting to the 2012 server in question, we're prompted for a username and password.  Failing to provide a valid username or password results in the login being rejected as it should. If we enter a valid username and password, the Remote Desktop connection window rapidly flashes and displays that it's trying to connect, but then instantly takes us back to the initial RDC prompt.  No connection happens, and no remote window appears.

So far I've tried using different remote users and different RDC clients with no luck.  I've also disabled the TCP chimney on the server having read some feedback that it might be causing the issue.  We don't have any firewall enabled on the server.  I've temporarily uninstalled our security software (Symantec Cloud).

In looking at the logs in the Server, nothing appears under Windows Logs\System Logs or Application Logs.  Under Applications and Services Logs - Microsoft - Windows - RemoteDesktopServices-RDPCoreTS - Operational, there's a series of log entries based on every attempt.  I see "The server accepted a new TCP connection from client 192.x.x.x), then Connection RDP-TCP#x created, a PerfCounter session starts, a warning event that "the network characteristics detection function has been disabled because of Reason Code:2", then "a channel rdplic has been connected between the server and the client using transport tunnel: 0", "a channel rdpcmd has been cconnected between the server and the client using transport tunnel: 0".  Immediately after that, I see "The disconnect reason is 0"  and then "The server has terminated main RDP connection with the client.

I've also tried rebooting the server and so far no luck.

Any ideas?

All help is appreciated!


Join our community to see this answer!
Unlock 1 Answer and 16 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 16 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros