VMware Workstation 10 - Redmine VM network interfaces wont come up

I have a major problem.

I have a remine VM installed and the Nic is configured in vMware for bridging network.
All was working but as soon as I shutdown the machine "Sudo shutdown -h now" and restarted the machine,I can seem to get a network connection for my redmine VM, I have tried everything restarted the Host machine and also run CMD and restarted via cmd
net stop vmnetbridge
net start vmnetbridge
and then again did a Sudo shutdown -h now and started the Redmine VM up again but still no comms.
This is freaking me out as all my confidential projects are on this redmine.

Any help would be greatly appreciated to get this working again please!
Jason LaskeyICT Systems and Network EngineerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gheistCommented:
Usually it happens when you change MAC addresses (like importing OVA)
You need to delete permanent udev rules (/etc/udev/rules.d/70-*) and remove MAC addresses from network scripts (Fedore/Rhel)
0
Jason LaskeyICT Systems and Network EngineerAuthor Commented:
@gheist

OK sure correct me please so do I do:

sudo -i
 nano /etc/udev/rules.d/70-persistent-net.rules

and then look for mac addresses and just remove the mac addresses there???

thank you so much for your assitance
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
That's correct....

you may find in your VM, you may have two network interfaces

eth0 and eth1.

But remove the mac address, and when the rules are re-generated, your actual mac address of your VM will be included.

This is a known issue with "cloning" Linux VMs.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Jason LaskeyICT Systems and Network EngineerAuthor Commented:
I only have one vm Nic ,

I just did a  rm /etc/udev/rules.d/70-persistent-net.rules
first backed up file though
Afterwards I did a /etc/init.d/networking restart

in VM WS
under the redmine VM Settings>NIc is set to  Bridged:....... and also Replicate physical network connection state

However still no IP address for my Redmine VM
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
can you check the mac address of the VM and VM Settings are the same ?

Can you also test NAT ?
0
Jason LaskeyICT Systems and Network EngineerAuthor Commented:
See screenshots both the Hypervisor MAC and the Redmine VM MAC's are the same
Image2.png
Image4.png
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Did you select NAT in the VM network settings ?
0
Jason LaskeyICT Systems and Network EngineerAuthor Commented:
no bridge, its always worked with bridge settings though and the cmd restart has always worked , just happened this morning when I shut the Redmine VM down and then started it up??
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
I just want to check if you get an IP Address in NAT mode
0
Jason LaskeyICT Systems and Network EngineerAuthor Commented:
I get an IP in NAT mode weird but its not on the same subnet as I am working on now
ie 10.0.0.x is current LAN
ip from VM is 192.168.0.x

Seems we half way there, any suggestions
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
The IP Address, from NAT is from VMware Workstation internal DHCP server.....

this IP Address is NATTED to your Internal LAN (10.0.0.x)

So this proves the VM is working correctly.....e.g. mac address can get a DHCP IP Address....

so do you have a DHCP serve on your LAN ?

It seems Bridged Mode, is not working or receiving DHCP ip addres....
0
Jason LaskeyICT Systems and Network EngineerAuthor Commented:
I do have a DHCP Server on my LAN yes
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Do you have more than one nic in the host?
0
gheistCommented:
Action 1
Delete udev net rules
Action 2
Remove MAC from ifcfg-eth*
Action 3
Reboot system (to restart udev)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jason LaskeyICT Systems and Network EngineerAuthor Commented:
Your comments were right how ever this didnt work as I had to do an ifconfig eth0 mac x.x.x.x and then do  sudo reboot .After the reboot it picked up an IP Address again
0
gheistCommented:
You can set fixed MAC via vmware too.
Though best is to just clear stored MAC ans dtart new life
Imagine person at next desk deploying same VM with same MAC....
0
Jason LaskeyICT Systems and Network EngineerAuthor Commented:
OK cool mind explain to me where in vMware I set the fixed MAC?
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Edit the VMX file.
0
Jason LaskeyICT Systems and Network EngineerAuthor Commented:
legend! will this propagate though to my linux vm?
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Yes, the udev net rules rules will pick it up, and add it to the

70-persistent-net.rules

this is what causes the issue, because at VM startup, the MAC address is written to the file.

If the MAC Address of the VM mismatches the MAC address in the file, networking does not work too well!
0
Jason LaskeyICT Systems and Network EngineerAuthor Commented:
Thanks mate,

As I said Legend as I have been battling with this issue contantly
0
gheistCommented:
It is just one time action - boot vm in single mode ONCE AFTER MAC CHANGE
Delete udev rules file
Delete MAC from ifcfg
and reboot like nothing happened.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.