Configure DHCP for PXE boot

I have installed SCCM 2012 on Windows 2012 R2 , I also installed WDS role in the same server.
I have another Windows 2012 server, I installed on it DHCP server and configured scope options as shown on the screenshot.

however when I start Windows 7 to PXE boot, I get the error shown on the Screenshot.

Any help will be very much appreciated.


Thank you

dhpxe
jskfanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Joshua GrantomSenior Systems AdministratorCommented:
change option 67 to only

\boot\x64\wdsnbp.com

Also, what is 192.168.50.207? the SCCM/WDS server?

What is 192.168.50.129?
0
jskfanAuthor Commented:
I deleted option 66 and 67, since DHCP , WDS, SCCM are all in the same subnet...

Now it gives me the option to press F12, but after I press F12..I get the window displayed in the screenshot below:
boot
0
Joshua GrantomSenior Systems AdministratorCommented:
you shouldnt have deleted those.

try changing option 67 to

\boot\x86\wdsnbp.com
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

jskfanAuthor Commented:
192.168.50.207 is the IP address of SCCM and WDS server (Both on one server)

192.168.50.129 is the DHCP server

on my SCCM server : the wdsnbp.com file is located under the following path:
C:\RemoteInstall\Boot\x64
0
jskfanAuthor Commented:
I put back the options 66 and 67 as you suggested, now I get the following screen
boot
0
Joshua GrantomSenior Systems AdministratorCommented:
change option 67 to only

\boot\x86\wdsnbp.com
0
jskfanAuthor Commented:
When I press F12,  it goes to normal windows start up
0
jskfanAuthor Commented:
<<change option 67 to only
\boot\x86\wdsnbp.com >>>

I did \boot\x86\wdsnbp.com and \boot\x64\wdsnbp.com
px
0
Joshua GrantomSenior Systems AdministratorCommented:
have you added the boot.wim and capture.wim to your WDS server?
0
vivigattCommented:
People always get it wrong !
If you have a real PXE server (like the one provided by SCCM/WDS/MDT), you DO NOT NEED options 66 nor 67. Actually, if you specify these options, your PXE server is useless and it can't, for instance, send different boot file names to clients that have different architectures.
You should read my article:
http://www.experts-exchange.com/Networking/Misc/A_2978-PXEClient-what-is-it-for-Can-I-use-PXE-without-it.html
and the comment I made to it.
Now, when you have removed DHCP option 66 and 67 (and made sure that you do not have DHCP option 60 set to PXEClient since your PXE server runs another host than the DHCP server), you should get your NBP (network boot program) downloaded and executed by your PXE clients. If not, it means that your PXE server is not working OK.
Microsoft changed its PXE server name and implementation quite a lot recently so I am not too sure what to check in your particular configuration. It is certainly a part/component of the "boot server" feature.
When you have your NBP downloaded and executed correctly (similar to what you've shared with your DHCP option 67 set), the PXE Portion of the boot process is OK. Now, it is WDSNBP that is controlling the client and it tries to download and boot your boot.wim image. If this is not working, you have to explore this lead.
0
jskfanAuthor Commented:
I followed your suggestions, and deleted options 66 and 67, and left the option 60 Empty.
I have rebooted to PXE, a good working Windows 7 with applications installed on it.
However I got the messages in the screenshots below:

pxerr
0
vivigattCommented:
OK, so you downloaded an x64 nbp for your client.
Don't you want an x86 client instead?
You must make sure that your VM guests can run 64bits OS.
Check this article for instance:
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1003945

Anyway, the PXE portion does work.
What does not is now that the NBP or, more probably, the boot image can't do it's job. This is what you have to investigate...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jskfanAuthor Commented:
I will get back to SCCM LAB later...

Thank you
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.