• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 189
  • Last Modified:

No incoming mail is working and smtp port 25 can not connect externally

I can not recieve incoming email and when I run an mxtoolbox check or Microsoft analyzer it says port 25 is blocked or can not connect. We have a static IP but our ISP who owns the router says the port is open. Are there any internal dns settings that need to be modified? Please advise
0
JRome225
Asked:
JRome225
1 Solution
 
stu29Commented:
Did the firewall on the Exchange server get flipped on?  If not do you have a firewall inside the router.  Is it blocking?

What happens when you try to telnet 25 to the internal IP of your exchange box?  Can you connect?  Can you send mail? This will tell you if your issue is at the server level or elsewhere.

What happens when you try to telnet 25 from external to the external IP?  Does it fail?

Try to run nmap against the router to see what ports are open.

You need to narrow down which device is your problem, and if you have no insight in to the router config then you have to work around that.
0
 
PerarduaadastraCommented:
Has the Exchange server worked before, or is it a new installation?
0
 
JRome225Author Commented:
This is a new installation. I dont have access to the router but the ISP said it is open. The windows firewall is on but isn't blocking smtp. We do have a Himachi vpn adapter setup as well. I set Exchange scope for external to use the server adapter IP and 25 rather than 587.
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
Simon Butler (Sembee)ConsultantCommented:
Does it work internally?
If so, then time for Simon's rule number one of ISP tech support: They lie.
As long as you work on the basis that all ISP tech support people are basically lying to you, then you will find life is much better.

If you can telnet to the port internally, and can do everything else that you need to do, then go back to the ISP and tell them that despite what they may say, the port isn't open. That could be on your router or elsewhere on their network.

Simon.
0
 
PerarduaadastraCommented:
"I set Exchange scope for external to use the server adapter IP"

I take it that this statement refers to outbound mail?
0
 
JRome225Author Commented:
yes, should all the adapters point to the server IP? Telnet still isnt working internally. Is there a role or IIS feature I need to modify? Also there is no ssl as of yet due to register.com not being able to verify the admin email address. My DNS is split zone and I set the Cname mail to point to the .local static server.
0
 
PerarduaadastraCommented:
If you can't telnet in from the LAN that suggests a problem on the server rather than the router. Have you tried disabling the Windows firewall temporarily to see if it makes a difference?

Have you checked that the Frontend Receive Connnector security settings are correct?
0
 
JRome225Author Commented:
I turned the windows firewall off, no success.

The current security settings are set to: TLS, Basic after TLS, and integrated Windows.
0
 
JRome225Author Commented:
If I unchecked all would that pinpoint the smtp stop?
0
 
mfrqnCommented:
Dou you have a receive connector for accepting emails from Internet?  Please visit http://technet.microsoft.com/en-us/library/bb125159(v=exchg.141).aspx for the configuration of Receive Connector for receiving emails from internet.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now