Mac access to shares very slow without FQDN

Hi,
I have a domain Joined Mac (10.8.5 & 10.9.4)
The windows AD is 2008 R2
The shares are on NetApp
The IP is coming from DHCP, which provides all the information including Search Domain

Now, when I go & try to access a share e.g. smb://Server/Share, it takes 10 -12 seconds to bring up the Authentication Windows,
However if I give the FQDN e.g. smb://Server.Domain.com/Share, it brings up Authentication Window immediately.

When the same exercise is done from a Windows Domain Joined computer, it works perfectly even without FQDN.


I would need to know how the same behaviour can be achieved on Mac that it works like windows client?
LVL 11
AcklesAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

serialbandCommented:
Dose forcing SMB1 help?

  cifs://://Server/Share
0
Justin Pierce, CEH, CNDANASA Cybersecurity EngineerCommented:
Hi Ackles,

I used to bring my Mac in very secure government networks that were MS dominant and had the same problems. That said, being the good little Net Admin I found Thursby software, ADmitMac, that turned my Mac into a true PC for AD environments. Here is a link to ADmitMac: http://www.thursby.com/products/admitmac

It worked wonders.

Hope this helps.

MacGuy47
0
AcklesAuthor Commented:
serialband,
The command never turns it into SMB1, that's a myth.
If you ever run Wireshark, you will see it still uses SMB1, the true way to make SMB1 is only by this command:


There's also a possibility to change all connections to use SMB1 system-wide (for all users) by entering this command in Terminal:

sudo sh -c "echo '[default]' >> /etc/nsmb.conf; echo 'smb_neg=smb1_only' >> /etc/nsmb.conf"


To restore the default SMB2 you simply need to delete the newly created configuration file (nsmb.conf) with the command:

sudo rm /etc/nsmb.conf



@Justin,
I am trying to understand why it does so? Not using 3rd party tools.

A
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

AcklesAuthor Commented:
Sorry, I meant wireshark confirms it still uses SMB2
0
serialbandCommented:
Ok, have you tried setting it to SMB1?
0
AcklesAuthor Commented:
Yes
0
AcklesAuthor Commented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AcklesAuthor Commented:
This was the exact solution-
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apple OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.