GPO startup computer script

I'm having problems with a GPO computer startup script to copy a batch file to the local 'all users' startup folder. The batch file executes fine locally.

Environment:
AD 2003 functional level
ServerX = Windows 2003 R2 DC Operations Master (RID, PDC, Infrastructure, schema, domain role), DNS
ServerY = Windows 2008 R2- secondary DC, DHCP server, backup DNS

I was hoping someone could give me a step-by-step for creating and testing the GPO, as I seem to be missing something.

This is the contents of the batch file:

xcopy \\ServerX\tmp\cah.bat "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup\" /y

Thank you for your time.
MRH-ITSAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cliff GaliherCommented:
If the batch file runs fine locally then it is likely a permissions issue. Keep in mind that startup scripts run as the local computer account, so both share and NTFS permissions need to allow that computer account read access for the file to be copied.
0
Neil RussellTechnical Development LeadCommented:
IF you put your cah.bat file into the NETLOGON directory on your AD controller(s) then you will more than likely solve the problem.  Then just use:-

xcopy \\DOMAIN.NAME\NETLOGON\cah.bat "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup\" /y
0
MRH-ITSAuthor Commented:
I've tried putting the batch file in the netlogon directory on ServerX, but to no avail.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Neil RussellTechnical Development LeadCommented:
Quick question... Why are you not using Group Policy to deploy the file directly? Its much easier.

Have a read.  http://www.group-policy.com/gp%5Cshortcuts.smp
0
MRH-ITSAuthor Commented:
I've tried to, but it's not working for me. Also, the link you referred me to does not seem applicable to Windows server 2003. Unless I'm missing something.
0
Neil RussellTechnical Development LeadCommented:
You stated you have BOTH 2003 AND 2008R2 servers in the domain.  You use the GPO Management on the 2008R2 server to configure the GP's and you can then follow that link.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MRH-ITSAuthor Commented:
That did it. Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.