Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 83
  • Last Modified:

Project Server 2010 and Multiple Cache files

we have a pair of Project 2010 servers that hide behind an F5...they work fine most of the time, but a few times a week we have issues...at first we thought was corruption but its looking like when a project is checked out its creating multiple copies of the project are being saved to the cache ie project1[1].mpc project1[2].mpc etc...at this point I don't know if its SharePoint or Project Server...we have MS involved but wanted to get others thoughts...
0
kf4ape
Asked:
kf4ape
  • 7
  • 3
1 Solution
 
kf4apeAuthor Commented:
we haven't tried local host files to bypass the f5, also we have source IP Persistence enabled as a test...previously we had cookie
0
 
kf4apeAuthor Commented:
we played musical nodes today in the F5...

also here is the symptom...MPC duplicate issue
0
 
kf4apeAuthor Commented:
hosts file exhibited the same behavior
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
BembiCEOCommented:
My question back is, what bothers you with the different versions of the local cached files. I can not read out of your question, what problem you have, I means what is going wrong with the projects.

Projects are locally cached, and as MS project has to handle changes on in the project clients a well as in the web access, I can see multiple copies of the cached files especially for projects, which are changed in the client as well as in the web access. Most of my duplicates are changes via PSI interface. But this doesn't mean to run into a problem at this point.

So far, I would say, it is a normal behavior.

So if you observe problems with the cache, can you describe, what problems you can observer with the cached versions?
Or are you in doubts about the multiple files?

If all local changes are saved, you can clean the cache, then they should be away.

By the way, using MS Project Client though a firewall was never a good idea. Just to avoid to convert your firewall to a swiss cheese.... Remote access with MS Project Client is better handled via VPN.
0
 
kf4apeAuthor Commented:
Different versions of the same local cache leads to corruption...that is what I am trying to solve for...as to the firewall/vpn, that is out of the pic now, we went on the same vlan as the server...a true ms win7 ISO, with office & proj ISO fully patch and nothing else is solid...now I am stepping through my image item by item with sccm
0
 
BembiCEOCommented:
Not necessarily but in your case, the global is affected....

What I can see is the following:
We wrote a PSI function which manipulated project files. As we had to delete the projects several times, the client created several mpc files for these projects. For other projects outside this PSI functionality, I can not see multiple files.

I would assume, that due to the deletion and recreation the projects got a new GUID and therefore a new file is created.
So far, nothing unusual with the exception, that these files become abandoned, so I can not delete them directly via MS Project.

In a different system I found a doubled global.mpc. Following the issues with this system I can point out, that this system had DEC / FEB 2014 CU installed what messed up the MSP_PROJECT_FRONT_END table on the SQL Server.
The problem was, that the Project Client uploaded all its local views to this table (even several times).
To indicate this issue, you can see int the MS Project Client Organazizer several views, filters and fields, which can not deleted anymore as well as doubled "all items" / "all resources" filters.
On one systems, which were affected by this CU, I can see double global.mpc files. Not a final proof as I deleted the profiles several times during cleanup.

Another common point with this system is, that I use a VPN connection and roaming profiles. Here I can see one profile with a doubled global.mpc (but without issues). The second one just seems to be abandoned.

On a JUN 2014 CU system, I tried to logon on two machines with the same account and logon overlapped to see, if it has something to do with two sessions on two machines. But my fast test didn't produce this effect.

So my idea would be now, that roaming profiles may have this effect.
Either sync issues (local profile, if roaming profile is not available or connection issues, drop dropdowns or sessions, which timed out.  
   
Another option is just the possibility, that in case of changes of the global template, the client may temporarily create a second one. Is the

For further investigation I would do now the following:
Make sure, all systems (including the clients) have the same CU level and not DEC 2014 CU or FEB 2014 CU.
If you work on more than one machine with the same profile, make sure that these machines have the same CU.
Clean the cache physically (delete the cache folder in the roaming profile) to avoid abandoned items.
Try to follow up, in which situation the issue comes back.

Just some thoughts from, my fast investigation, maybe it points you to the right reason.
0
 
kf4apeAuthor Commented:
so far with my investigation, it looks to be the adobe flash plugin inside our image laydown, they are also laying down the latest CU on the servers...its not just global.mpc, but also some other items
0
 
kf4apeAuthor Commented:
so I figured out its the activeX edition of the plugin (doesn't matter rev)...we uninstall it and all is right with the box...
0
 
BembiCEOCommented:
Mmh, interesting....
I just searched my computer for *.mpc files? And found some files which are files encoded with a audio  f32l codec.
At least this give me the impression, that it has not necessarily alone to do with the flash plugin but just with an wrong interpretation of the file extension. Possibly the flash plugin involves in the file extension.

If this is the case,  the file itself may be blocked as catched by another application and therefore a new file is created.
You may check the file association of *.mpc files in the operation system. It should not be associated to any other application. In may case, VLC player tooks it (without an visible issue) but depends from the application.

So, flash player may just be one of the applications which interprets (and therefore involves) the file extension as audio file. As this extension is really used in rare cases for media files, this can be the issue.
0
 
kf4apeAuthor Commented:
well due to politics this was shelved at the company...never really solved and MS was no help
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 7
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now