Exchange 2007 database won't mount due to E00 corruption

I rebooted my Exchange 2007 server due to some issues I was having and my main database will not mount now. I should note that this database is ridiculously large (420GB) which of course contributed to some of my issues in the first place.

The key error in the event log seems to be - "MSExchangeIS (1984) First Storage Group: Corruption was detected during soft recovery in logfile C:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group\E00.log. The failing checksum record is located at position END. Data not matching the log-file fill pattern first appeared in sector 2047 (0x000007FF). This logfile has been damaged and is unusable. "

I tried deleting the .chk file and it replayed all the logs, but gave the same error. eseutil /ml on e00.log fails as well. I think I have all the necessary files, but e00 is just corrupt.

I have a backup from 2 days ago. I'm currently copying this storage group folder to the server (i hope that's all I'd need) in case I need to go this route though at 420 gigs, it's going to take awhile...

I'm really hoping to get things back up and running in the next few hours before the start of the work day. Thanks.
ruhkusAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ruhkusAuthor Commented:
So in looking up some other posts, I see there's a difference between 'eseutil /ml e00.log' and 'eseutil /ml e00'

I'm currently running it with e00, but there's a bunch of transaction logs so it'll take some time.

I did see a suggestion to run 'eseutil /r e00 /i /a' which I have yet to run, so wondering if this would be my next step.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ruhkusAuthor Commented:
This worked.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.