You were not connected because a duplicate name exists on the network.

I created a CNAME record (ACCOUNTS) in our DNS that points to host record (SERVER01).
I can ping the CNAME record and host record

However, when trying to browse to the CNAME \\ACCOUNTS I see an error...
You were not connected because a duplicate name exists on the network. Go to System in Control Panel to change the computer name and try again.

The machine generating the error is running Windows Server 2003 R2 (SP2 installed)
I've tested from Windows 7 and Windows Server 2008 clients and they do not have the issue, however XP and other 2003 servers do

We do not use WINS and do not have a GNZ, there are no other records for "SERVER01" and the hosts file does not have anything in it.

Any help would be greatly appreciated!
antoniokingAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Pete LongTechnical ConsultantCommented:
On an affected machine

open regedit and navigate to:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters
Create a new DWORD with the following details:
Value name: DisableStrictNameChecking
Data type: REG_DWORD
Type: Decimal
Value: 1
Then reboot the Host.

Any difference?
0
Pete LongTechnical ConsultantCommented:
Sorry - do that on the SERVER!
0
Pete LongTechnical ConsultantCommented:
Actually some sites say client, others say server, my gut feeling is change the client
0
Introducing the "443 Security Simplified" Podcast

This new podcast puts you inside the minds of leading white-hat hackers and security researchers. Hosts Marc Laliberte and Corey Nachreiner turn complex security concepts into easily understood and actionable insights on the latest cyber security headlines and trends.

antoniokingAuthor Commented:
Hi Pete
I really should have mentioned, I have already set the DisableStrictNameChecking DWORD registry setting on the problem client server.
0
Pramod UbheCommented:
Please see below KB, you might need to add SPN which is a common practice for duplicate names -

http://support.microsoft.com/kb/281308
0
antoniokingAuthor Commented:
setspn is not a recognised command on our 2003 servers

Do I run this command on our DNS servers?
0
Pramod UbheCommented:
You need to have admin tools installed on 2003 server for setspn command
0
antoniokingAuthor Commented:
Ok, I've installed Admin tools and searched C drive... setspn.exe doesn't exist!
0
Pramod UbheCommented:
are you able to execute it in command prompt?
0
antoniokingAuthor Commented:
Sure, when running from command line...
'setspn' is not a recognized as an internal or external command, operable program or batch file.

This is why I searched the C drive for the exe.
0
antoniokingAuthor Commented:
Ok, the setspn.exe is actually part of the 2003 Support tools not Admin tools
Downloadable from here... http://www.microsoft.com/en-us/download/details.aspx?displaylang=en&id=7911

I've ran the command but got an error
C:\Documents and Settings\Administrator>"C:\Program Files\Support Tools\
setspn.exe" -a DOMAIN/ACCOUNTS SERVER01.DOMAIN.NET
FindDomainForAccount: DsGetDcNameWithAccountW failed!
Unable to locate account SERVER01.DOMAIN.NET
0
Pramod UbheCommented:
my bad, it is support tools not admin tools.

execute below two commands (assuming accounts is ur alias and server01 is actual server name; replace domain.com with your actual domain name) -


setspn -a host/accounts server01
setspn -a host/accounts.domain.com  server01
0
antoniokingAuthor Commented:
Hi
Thanks for that, commands executed successfully
Unfortunately the error is still occurring when trying to browse to \\accounts
0
Pramod UbheCommented:
Have you done registry changes? It will take some to replicate SPNs in AD.
Also you might need to reboot server01.
0
antoniokingAuthor Commented:
Sure, I did the registry change. I have rebooted server01. still not working but I can wait

I performed the setspn commands on server01. Wouldn't it be best for me to do this from a DC?
0
Pramod UbheCommented:
Yes, it helps in replication but by this time it should get replicated.
 Can you try accessing the share with \\accounts.domain.com or check if there is any duplicate name in WINS or set a diff. alias if possible
0
antoniokingAuthor Commented:
Hi, thanks for taking the time to reply!
Unfortunately the same error occurs when trying to ping the FQDN
0
antoniokingAuthor Commented:
Also, we do not have WINS installed.
0
Pete LongTechnical ConsultantCommented:
You should only need to run setspn on a 2008R2 (or newer server)?

I've just replicated it it on the test bench with XP clients and a 2003 server, change the reg key on the server, bounce the server service. and reboot the client - and it works

Make sure you have CNAME and not A records in DNS and make sure there's nothing in the hosts files.

PL
0
antoniokingAuthor Commented:
Hi PL
Records are definately CNAME records.
Hosts file is definately empty

I've created another CNAME 'TESTCNAME' pointed it to a different A record.
Same error, and interestingly the error also occurs on Windows 7 clients too (when trying to access \\TESTCNAME)

Regards
0
Pete LongTechnical ConsultantCommented:
Server 2003 and clients are Win 7 correct?
0
antoniokingAuthor Commented:
The DNS servers are 2008 R2
The server I am creating an alias for is 2003
The clients experiencing the issues initially were XP and 2003 only
But since creating another alias, 7 clients also see the same error.. but only for the new 'test' cname created.
0
Pete LongTechnical ConsultantCommented:
I've just done the same and the registry change on the server fixed it straight away
0
Pete LongTechnical ConsultantCommented:
OK Install this update http://support.microsoft.com/kb/970536

Then try the setspn commands i.e.

setspn
0
antoniokingAuthor Commented:
Hi thanks for the suggestions
I've installed the update, checked the registry setting is correct (it is) restarted the server service and performed the setspn commands again.
The issue is still persisting.

Did you note my earlier comment that a test cname I created is un-browsable from Windows 7 clients as well?

Regards
0
kevinhsiehCommented:
Optionalnames in the lanmanserver portion of the registry always works for me.

You have to reboot the server service after making the change.

http://www.techrepublic.com/blog/the-enterprise-cloud/adding-multiple-netbios-names-for-windows-servers/
0
antoniokingAuthor Commented:
Hi Kevin
The server has been rebooted, I have also tried restarting the server service.
0
antoniokingAuthor Commented:
I have removed the 2003 server off the network and replaced with a new 2008 server. Which of course, means the issue is no longer presented.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
antoniokingAuthor Commented:
Server removed
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.