When trying to lonch web start application at client machine, it is downloading the .jnlp file rather executing

Sir,
I have developed a web start java application. When I am trying to lonch at customer machine it is downloading the jnlp file rather executing.  When I looked into Control Panel\Programs\Default Programs\Set Associations the .jnlp extension file entry not exists.
Secondly, in other machines it is showing

Your security setting have blocked a self signed application from running

Please help.

Regards
MILIND_JOGAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CEHJCommented:
 When I looked into Control Panel\Programs\Default Programs\Set Associations the .jnlp extension file entry not exists.

Is javaws.exe even present on that box?

Your security setting have blocked a self signed application from running
Self-signed no longer cuts it i'm afraid. Whoever signed it will have to resign it with a proper cert
0
MILIND_JOGAuthor Commented:
Sir,
Thanks  for reply.

My PC doesn't have javaws.exe.

Regards
0
CEHJCommented:
Then that's your problem. You can't associate a file extension with a program that doesn't exist on your system. Install Java

You should get the people who wrote the app to investigate auto download of the runtime in addition to signing it with a proper cert
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

MILIND_JOGAuthor Commented:
Sir,
I am using NetBeans to develop application. Previously While building the project, I setup the property of project/web start/signing/customize/self-sign by generated key. As per your suggestion what I understood, I changed the property to Sign By a Specified key. After rebuilding , I put every thing on the root of web tomcat. The application is available to run on server itself, but unable to open the page on client machines. There it is still showing the message "Your Security settings have blocked a self-signed application from running".

Secondly, I understand your comment about javaws.exe. Please suggest me how to get that. I do understand that I do not have the basic idea about that. Please help.

Regards
0
CEHJCommented:
As per your suggestion what I understood, I changed the property to Sign By a Specified key.
So did you purchase a proper signing certifcate? If not, you need to do that in order to be able to use it.

Secondly, I understand your comment about javaws.exe. Please suggest me how to get that.
javaws normally comes with the Java runtime. It's probably not installed on the machine you're trying. You need to install it
https://java.com/download
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MILIND_JOGAuthor Commented:
Thanks a lot. My query is resolved under your guidance.

Regards
0
CEHJCommented:
:)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Java

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.