iSCSI LUN being available on one server but not the others (in a cluster)?

Hi,

I've got a cluster with 3 hosts. They all have the iSCSI storage adapter enabled. I've entered the same iSCSI server address (a QNAP) and the same iSCSI target name on all theree servers but only one of them gives me access to the LUN?

Why?

It used to work for all three ...

Any help is appreciated, thanks
XeronimoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mcsweenSr. Network AdministratorCommented:
I'm not familiar with QNAP but I would check the following to start:

1. Make sure the LUN doesn't have an ACL on it.  If it does modify it to allow all 3 server's iSCSI IP Addresses.
2. If Authentication is enabled (usually CHAP) on the LUN make sure you enter this information on the server.
3. If discovery is enabled on the SAN  you should be able to discover the targets from the iSCSI initiator on the server then attach like that.  If you can't discover the targets start working backwards to make sure you have full connectivity between the server and SAN.
0
gheistCommented:
Check reverse DNS records match forward ones.
0
XeronimoAuthor Commented:
Hi, thanks for answering.

The LUN doesn't have an ACL on it and authentication is not enabled.

I used to get the LUNs by adding a iSCSI server to the dynamic discovery on the VMWare host but now it remains empty ...

I see the LUN on the QNAP and I can access it on that one VMware host so it's active?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

XeronimoAuthor Commented:
gheist: for which devices? the iSCSI host? or the VMware hosts?
0
Mr TorturSystem EngineerCommented:
Hi Xeronimo,
here are some suggestions :
- nothing happen recently on your ESXi OS, or network switch (or dedicated iSCSI switch) ? (hardware or major software change)
- no recent update installed on your ESXi hosts or maybe applied not to all ESXi hosts in your cluster?
- at least I suppose you try to rescan storage on the two hosts having the isssue...?

I suppose you are speaking of iSCSI Software adapter enabled on your hosts.

- Are you sure there is absolutly no differences between the 3 hosts in iSCSI software adpater properties, in both tab (statis discovery and dynamic discovery) ?
- sure it is a little dumb and I do not say you are, sincerely, but did you try to reboot the 2 ESXi hosts having the issue? (if you can do it without having to shutdown vm in your cluster you should try).
- are all the physical iSCSI links in a good state with these 2 hosts?
- is there any menu on the QNAP to see hosts attached? if yes do you see all hosts?

Do you work with vlan on your switch?
0
mcsweenSr. Network AdministratorCommented:
Did you rescan the VM cluster for new datastores?

Right click the Cluster in vSphere client, ReScan for Datastores, Check both boxes, OK (This takes a while but does not interfere with ESXi operations)
0
XeronimoAuthor Commented:
mcsween: I did rescan the cluster for datastores now. Now new LUNs though under the respective iSCSI storage adapter.

But I got the following message from my Veeam One Monitor (from before the cluster rescan):

Fired by event: esx.problem.storage.iscsi.discovery.connect.error
Event description: iSCSI discovery to 192.168.1.52 on vmhba33 failed. The iSCSI Initiator could not establish a network connection to the discovery address.
Initiated by: Not Set
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
are you missing a datastore or a lun ?
0
XeronimoAuthor Commented:
I'm missing the LUNs.
0
mcsweenSr. Network AdministratorCommented:
I get weird errors from my EQL SAN Manager like that when I'm doing LUN stuff.  I'd watch to see if the error pops again or if it popped because of the re-scan.

Are you seeing the missing LUNs now?
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
So the LUNs are missing from Storage list ?
0
XeronimoAuthor Commented:
They did not get displayed under 'details' in the 'storage adapter' list of two of the three servers.

What I finally did now was to create NFS connections to the QNAP and moved the couple of VMs I had on the iSCSI target to the NFS datastore. That datastore is now visible to, and accessible by, all three VMware hosts.

Just wondering: how would one choose between iSCSI and NFS anyway in the first place? Any reason to prefer the one over the other?
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Well that doesn't really solve the issue with iSCSI!

iSCSI versus NFS, NFS has been getting better and is now favorited by some vendors e.g. NetApp for VMware Deployments, because of the implementation of 10GBe for NFS.

Some suggest NFS is simpler to implement than iSCSI, as you do not need to create LUNs, Mappings etc

BUT, I would check and test performance, and see which works best for you.

Do you want to continue with iSCSI LUN issue or not ?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
XeronimoAuthor Commented:
You're right, it does not solve the problem with the iSCSI. But I chose to drop it because implementing the NFS solution was quicker and I've got other stuff to do as well -.-

So we don't need to continue with the LUN issue but thanks anyway!
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
No problems, I would enable Jumbo Frames.

and if you have time, test iSCSI versus NFS for performance.
0
XeronimoAuthor Commented:
Ok, thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.