Cent OS 7 SSH Putty

I need to access my Cent OS box from Putty ... how do I set that up? Or is it just a port forward I need to make on the router? It's a standard install.
Starquest321Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

convergintCommented:
OpenSSH is already installed by default so there's nothing you should need to do on the server.  On your router you just need to forward port 22 on TCP.  If you want to harden it more there's a great article here: http://wiki.centos.org/HowTos/Network/SecuringSSH
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Pepe2323Commented:
Hi

If you need to connect to your CentOS using putty ( ssh ) from outside , as convergint said you need to perform a port forward on port 22, also verify ssh daemon is running  running the following:

service sshd status -- u shall get a message saying is running in case is not then start it
service sshd start

Check if you have enabled the iptables on ur Centos ( Linux Firewall)

service iptables status --- > if they are running u have two options define a rule in order 22 port be opened or disabled

service iptables stop

if you define u want to keep running iptables then define the rule to allow ssh ( port 22) be opened

vi /etc/sysconfig/iptables

-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT

reload the service

service iptables restart

At this point u can test ur ssh service if you are connected on the same network

Finally depends of the router vendor perform a port forward on port 22

Regards.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.