Symantec BUE + Netapp NDMP authentication

I have Backup Exec 2010 R3 with the NDMP license, trying to backup data from a Netapp FAS3050.

This particular backup job has been running correctly for two years now but last week I upgraded the tape library and for some reason that job gets stuck at the Queue phase and never progresses further.  In troubleshooting I removed and created a new backup account following the instruction here: http://networkadminkb.com/KB/a16/how-to-configure-a-netapp-fas-controller-to-use-ndmp.aspx

But every time the test fails saying how the logon account provided does not have the required permissions.

I did create an NDMPD password via ndmpd password <accountname> on all four of the new backup accoutns I've created and tried thus far.. BUE however does not like any of them.
LVL 14
Ben HartAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Paul SolovyovskySenior IT AdvisorCommented:
Try doing a small NDMP backup to disk and see if it's an issue with disk to disk or disk to tape.
0
Ben HartAuthor Commented:
Sorry for the latency.  This weekend I noticed the job was in a Queued state.  I cancelled it and attempted a Test Run only for it to report the media was no over writable.
So looking I noticed the scheduled backup job is set to use a correct 'device' which is a partitioned slots 4, 5, and 6 on my Tandberg autoloader.  The media in those slots is associated with a set that's configured to disallow overwriting for 4 weeks.

So the job marked the media as overwrite protected but never actually processed any data.

I places two new tapes into those slots, associated them with the same set.  Then after an inventory on those slots I re-tried the test job which promptly failed again.

"Insufficient online or nearline media is available to start job."
0
Paul SolovyovskySenior IT AdvisorCommented:
Try writing to disk see if that works.  What I'm trying to delineate is whether the issue is authentication or hardware related
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Ben HartAuthor Commented:
If it helps I use the same library (a different slot partition) for another job that backs up a couple windows servers... the job performs admirably.

Ill create a test job selecting a small subset of the NDMP data to disk though.
0
Ben HartAuthor Commented:
Looks like the test job to disk is working.. It's been 'Running' now for over 20 minutes. So.. i re-checked the partitions and the NDMP and widows BU jobs.  The 'Friday' Media set for the windows job is configured as:

Overwritable Protection: 2 days
Append Period:  infinite

The 'Keep Data for 4 Weeks' media set for teh NDMP job is configured as:

Overwrite Protection period: 4 Weeks
Append Period: 6 Days
0
Paul SolovyovskySenior IT AdvisorCommented:
So we know it's not an authentication issue if it's start to write data to disk, I think this answers the original question you had.  Now with the tape the overwrite can be giving you an issue.  Create a new media set to test and point to the same slots you've been using but use allow overwrite option to test.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ben HartAuthor Commented:
The original issue it still an issue.. sort of.  I mean why would BUE say my cred are bogus but then allows them during the actual job?  I checked LiveUpdate before posting earlier and it did d/l and install a single update, just to make sure.

I'll try the new media set and report back.
0
Ben HartAuthor Commented:
Ok new tapes, new media set, new backup job.. job still sits in the queued state.  Test Backup Jobs all fail with Unable to mount media.

What I don't get is BUE can read the tapes in these slots without fail.
0
Ben HartAuthor Commented:
Backup job completed.  Not sure how or why but it did.  BUE not being able to validate the NDMP credentials is still rather stupid.  But creating a new job, selection list and media set appeared to have done the job.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.