ActiveSync not getting configured automatic

I have a DAG with three members, All servers holding all the 3 roles.
All working internally excpet activesync not getting configured automatic.

I added external domain as Alternate UPN Suffix and changed a test user's profile account to test@externaldomain.coim

Still server name not coming automatic in Android (Activesync).

Anyone can guide me on this?
LVL 30
MAS (MVE)EE Solution GuideAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

George SasIT EngineerCommented:
0
MAS (MVE)EE Solution GuideAuthor Commented:
I already set OWA URLs I am talking about activesync autodiscover.
0
George SasIT EngineerCommented:
Set-ActiveSyncVirtualDirectory -Identity "COMPUTERNAME\Microsoft-Server-ActiveSync (Default Web Site)" -ExternalURL "https://servername.com/"

Set-ActiveSyncVirtualDirectory -Identity "COMPUTERNAME\Microsoft-Server-ActiveSync (Default Web Site)" -ActiveSyncServer "https://servername.com/"

Use this tool to check it and see why it is not working :
https://testconnectivity.microsoft.com/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

MAS (MVE)EE Solution GuideAuthor Commented:
-->Set-ActiveSyncVirtualDirectory -Identity "COMPUTERNAME\Microsoft-Server-ActiveSync (Default Web Site)" -ExternalURL "https://servername.com/"
-->Set-ActiveSyncVirtualDirectory -Identity "COMPUTERNAME\Microsoft-Server-ActiveSync (Default Web Site)" -ActiveSyncServer "https://servername.com/"

COMPUTERNAME is netbiosname of the exchange server?
Here servername.com is domainname or netbiosname of the exchnage server?
0
George SasIT EngineerCommented:
Computername - Your CAS server computername. (netbios name)
Example :
Set-WebServicesVirtualDirectory -identity "CAS01\EWS (Default Web Site)" -externalurl https://mail.contoso.com/EWS/Exchange.asmx -BasicAuthentication:$True

Here is a short guide :
http://mshiyas.wordpress.com/2010/07/06/how-to-configure-and-verify-autodiscover-for-exchange-2007-and-2010/
0
MAS (MVE)EE Solution GuideAuthor Commented:
This is set already.  Test is all success.
Still Activesync not working automatic.

server name not coming automatic.
it is showing domain.com as server name instead of mail.domain.com
This is the error
"Failed to search Exchange server automatically. Enter settings manually"
0
George SasIT EngineerCommented:
Set-ActiveSyncVirtualDirectory -Identity "servername\Microsoft-Server-ActiveSync (Default Web Site)" -ActiveSyncServer "https://mail.company.com"

Make sure you have the DNS entries in order for Autodiscover and so long.
0
MAS (MVE)EE Solution GuideAuthor Commented:
I set this still not working automatic showing the same error
"Failed to search Exchange server automatically. Enter settings manually"

Autodiscover and common name records are added in external and internal DNS servers
0
George SasIT EngineerCommented:
What phone is this ?
Try on a Nokia and an iPhone. If it works there then use another software than the one built in on the problematic phone. I recommend TouchDown.
I have seen this problem on some Samsung and Sony phones.
0
MAS (MVE)EE Solution GuideAuthor Commented:
I tried Iphone showing the same error. Server name not coming automatic
0
George SasIT EngineerCommented:
And what does https://testconnectivity.microsoft.com/ say ?
It should give you detailed instructions on how to correct the errors.

If name does not come automatically it is either one of this :
- You use a different default e-mail domain than the one that you try to configure on the OWA.
- Your ActiveSync configuration on the IIS server is wrong.
0
MAS (MVE)EE Solution GuideAuthor Commented:
:- You use a different default e-mail domain than the one that you try to configure on the OWA.
Its configured to use internal domain
Activesync urls configured as our external name
0
George SasIT EngineerCommented:
Ok, then the user does have 2 e-mail addresses or only one ?
Like username@internaldomain.com + username@externaldomain.org ?
And you log in with username@internaldomain.com but the primary e-mail address is username@externaldomain.org ?

What does this command return :
test-OutlookWebServices -identity:youruser@externaldomain.org | ft * -AutoSize -Wrap
0
MAS (MVE)EE Solution GuideAuthor Commented:
Attached the result of the above command
results.txt
0
George SasIT EngineerCommented:
That looks ok, the only error is the SSL.
The certificate for the URL https://exch201 0-2.nasser.com/autodiscover/autodiscover.xml is incorrect. For SSL to work, the certificate needs to have a subject of exch2010-2.nasser.com, but the subject that was foundis autodiscover.nsportq8.com. Consider correcting service discovery, or installing acorrect SSL certificate.

This is from inside.
But please DO test with https://testconnectivity.microsoft.com/ and see what errors you get !
0
MAS (MVE)EE Solution GuideAuthor Commented:
Any update?
0
George SasIT EngineerCommented:
From me ?
I asked you 3 times to test from outside also :
"This is from inside.
But please DO test with https://testconnectivity.microsoft.com/ and see what errors you get ! "

Did you tested from outside ?
Inside all looks ok.
0
MAS (MVE)EE Solution GuideAuthor Commented:
I tested from inside and outside both failed.
But  I have SRV and autodiscover created
0
MAS (MVE)EE Solution GuideAuthor Commented:
Thanks it worked .
A final question. How do teh activesync client get the external name(I mean the server name field) ?
Where we configured that server name in activesync virtual directory?
0
George SasIT EngineerCommented:
It gets it from the Exchange.
It will check for tha autodiscover.domainname.com and look for the autodiscover.xml file with the config.
0
MAS (MVE)EE Solution GuideAuthor Commented:
My question is not clear to you I guess. Before it was connecting to domain.com n throwing the error.
Now it is connecting to mail.domain.com how the client get this name and where we mentioned this name in server?

Any update on the above?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.