• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 374
  • Last Modified:

Sql Server Agent Job Logs

Hi All,

I have a bunch of jobs on a server.  Some of the jobs are not reporting any history.  I'm pretty sure this is due to the fact that there's a heart beat job running on the server (runs once a minute, every minute, every day).  

Is there a way to configure SQL to either (in order of preference)

1)  Not log the heartbeat job
2)  Limit the size of the jobs to X number of instances (eg: keep only a record of the last number of times run).
3)  Expand the log size to accommodate everything

Thanks in advanced.
0
Kyle Abrahams
Asked:
Kyle Abrahams
2 Solutions
 
Vitor MontalvãoMSSQL Senior EngineerCommented:
3)  Expand the log size to accommodate everything

In SSMS go to SQL Server Agent and right-click for properties and make the changes you need in History.
Capture.PNG
0
 
Scott PletcherSenior DBACommented:
I prefer to uncheck the "Limit size" and specify a "Remove agent history" time period.  You can specify 3 months if you want.  That keeps all history for a full three months, rather than a raw row count, which could of course be inflated by frequently run jobs.
0
 
Kyle AbrahamsSenior .Net DeveloperAuthor Commented:
Thanks guys.
0

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now