Solved

Windows Server 2012 get Remote Desktop back to standard 2-user CAL free version

Posted on 2014-09-03
4
566 Views
Last Modified: 2014-09-03
I have a server that I accidentally enabled the time-bombed version of Remote Desktop.  I can't figure out how to get it back to the default installation.  I know how to reset the time bomb in the registry, but it will just keep expiring.  I'd like to figure out how to get it back to a default installation that allows 2 users with no licensing.
0
Comment
Question by:DavinDameron
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 37

Accepted Solution

by:
Neil Russell earned 250 total points
ID: 40302236
Just remove the RDS ROLE in server manager maybe?
0
 
LVL 58

Assisted Solution

by:Cliff Galiher
Cliff Galiher earned 250 total points
ID: 40302241
Let me be VERY CLEAR. There *has never* been a "two CAL" version of RDS. A server that has not been configured for RDS allows 2 simultaneous connections (THEY ARE NOT CALs!!!!) for *ADMINISTRATIVE* purposes only. Users have *NEVER* been allowed to use these sessions for LOB applications. Ever. It is illegal. Always has been. If even one user is connecting for one app, an RDS CAL is required. That user does not get the "two free" benefit.

Okay. Now that I've beaten that completely. Adding the RDS role required RDSH or RDVH role will require licenses. Removing the RDSH or RDVH role will revert to administration mode. That is how it gets turned on or turned off. By adding or removing one of those roles. So you can run the "remove roles and features" from server manager and remove the role, and yes, that can have an impact on any applications that have been installed on the server. There is no way around that.
0
 

Author Comment

by:DavinDameron
ID: 40302388
Cliff,

Thanks for the comment.  This is where I was getting hung up.  I assumed I could go into "Add roles" and then uncheck RDS.  It won't let you.  I finally realized there is a separate applet under server manager to remove roles.  Once I did this and removed RDS, all is working as it should.  Boy do I feel stupid on that one.  Thanks!

PS, yes this is for administrative purposes only.
0

Featured Post

Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In my previous 24 VMware Articles (http://www.experts-exchange.com/ARTH_1864316.html?arthOrderBy=3&arthSort=1#arth), most featured Intermediate VMware Topics. My next series of articles concentrated on topics for the VMware Novice;   If you would…
The following article is comprised of the pearls we have garnered deploying virtualization solutions since Virtual Server 2005 and subsequent 2008 RTM+ Hyper-V in standalone and clustered environments.
In this Micro Tutorial viewers will learn how to use Boot Corrector from Paragon Rescue Kit Free to identify and fix the boot problems of Windows 7/8/2012R2 etc. As an example is used Windows 2012R2 which lost its active partition flag (often happen…
This tutorial will walk an individual through the process of configuring their Windows Server 2012 domain controller to synchronize its time with a trusted, external resource. Use Google, Bing, or other preferred search engine to locate trusted NTP …

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question