Solved

RemoteApp Nightmares!! Server 2012 R2

Posted on 2014-09-04
3
82 Views
Last Modified: 2016-06-14
I am losing the will to live!
I have set up several remoteapp server with no problems whatsoever however this one is just being a pain!
I set it up originally and tested the connections to published apps, all was well with the collection I created EXCEPT that calculator and wordpad would not work. For some reason they hadn't picked up the remote gateway setting and would not connect to the server. All other non OS installed apps worked fine but the client wanted calc and wordpad.
So, I uninstalled RDS and reinstalled it with the QuickCollections, this seems to have worked in the respect that the calc and wordpad apps pick up the remote gateway BUT now I have two icons for each app on the web page and when I fire them up they tell me they are not in the list of allowed apps.
Under the RDS configuration I only have the one collection, the QuickCollections, under the RemoteApp Porograms pane I have a message saying that I need to create a collection to publish, if I add anything I get even more icon duplication but the apps DO work.
What I need to know is how do I uninstall RDS in its entirety to ensure no duplication or hangovers from previous configuration?
I have used the add remove roles wizard but this seems to leave traces of what was there before!
0
Comment
Question by:sparky1977
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 37

Accepted Solution

by:
Mahesh earned 500 total points
ID: 40305240
Check below registry key on connection broker server
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server\CentralPublishedResources\PublishedFarms\remoteapps\Applications

Remove any stale entries \ unwanted entires from here, it should help
Do not forget to backup registry before making any changes
0
 
LVL 1

Author Comment

by:sparky1977
ID: 40306341
Hi Mahesh,

Just what I needed, I don't know why the server would keep information about previously installed apps but hey ho!
Its working perfectly now, such a simple thing!

Many Thanks
Andy
0

Featured Post

[Webinar] Code, Load, and Grow

Managing multiple websites, servers, applications, and security on a daily basis? Join us for a webinar on May 25th to learn how to simplify administration and management of virtual hosts for IT admins, create a secure environment, and deploy code more effectively and frequently.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I'll explain how to setup a Plex Media Server (https://plex.tv/) on a Redhat (Centos) 7 based NAS with screenshots to help those looking for assistance.  What is Plex? If you aren't familiar with Plex, it’s a DLNA media serv…
What to do when Windows Update is not working correctly? What tools can I use to detect the cause of the malfunction problem? What does this numeric error code mean? These and other questions that you have been asking in the past are answered here (…
In this Micro Tutorial viewers will learn how to use Windows Server Backup to create full image of their system. Tutorial shows how to install Windows Server Backup Feature on Windows 2012R2 and how to configure scheduled Bare Metal Recovery backup.…
In this Micro Tutorial viewers will learn how to restore single file or folder from Bare Metal backup image of their system. Tutorial shows how to restore files and folders from system backup. Often it is not needed to restore entire system when onl…

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question