Hyper-v on windows 8; Unable to intialize

hi experts,

I am trying to setup my lenovoT420s Windows 8 laptop with hyper-v and create a VM. I have enabled virtualization in the BIOS, installed Hyper-v, ran through the setup wizard to create a VM. Pointed it at an ISO for the OS.
Once I complete the wizard and try to start the VM I get the following error message:

"The application encountered an error while attempting to change the state of 'VMNAME'.  'VMNAME' could not initialize"

When I look in Event Viewer the event ID: 3040 is logged.

I am by no means a Hyper-V expert so my guess is that I have a setting wrong or something easy, but I have no idea. Can you guys help me out?

Thank you.
eagle3344Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Brad GrouxSenior Manager (Wintel Engineering)Commented:
I know the T420s can run Hyper-V just fine as I used one with a Hyper-V lab and six VMs for about two years.

First thing I'd do is delete the current VM and start fresh. It might not work but it only takes a few seconds to do.

The Event ID Information leads me to believe it may be a permissions issue, so I'd double-check to make sure that the user account you're trying to use to create the VMs is a local administrator.

Also, insure that the VM you are creating isn't allocated too many resources. Start with 1CPU, 2GB of RAM and 30GB of disk space and build the machine and then raise the specs from there as needed. I regularly run 2012 R2 VMs on my Surface Pro at 1CPU, 1GB of RAM and 10GB of Hard Drive space without issue.
0
eagle3344Author Commented:
Thanks for the suggestions Brad.

I deleted the VM and recreated it using the specs that you suggested (1 cpu, 2GB of RAM and 30GB hard drive) and put it in a folder in my 'My docs' folder. I started the VM and got the same error.
0
Lee W, MVPTechnology and Business Process AdvisorCommented:
Make sure you have the appropriate BIOS settings - It's not enough to make sure virtualization is enabled - you need to make sure DEP is also enabled.

For more information see the first 4 bullet points in this article (EXCLUDING the Quick Summary) which details enabling Hyper-V on Windows 8.

http://msdn.microsoft.com/en-us/library/windows/apps/jj863509%28v=vs.105%29.aspx#coreinfo
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

eagle3344Author Commented:
Thank you, Lee. I checked my bios against the settings suggested and I think I have everything correct although all settings were not available:

SLAT - Could not find this anywhere
Hardware assisted virtualization - Could not find
Data Execution Prevention - Enabled
Intel VT-d feature - Disabled
Trusted Execution - Could not find
Intel Virtualization Technology - Enabled
CPU Core Multiprocessing - Enabled
Intel Hyperthreading - Enabled

I ran coreinfo.exe and the VMX setting (hardware assisted virtualization) DOES NOT have a star next to it. Could that be because of a wrong BIOS setting?  I also could not find the setting for SLAT (EPT in the left column).

I ran the MachineSlatStatusCheck and it tells me I have a SLAT Capable machine.

I also checked in Control Panel and it tell me my processor supports hardware based DEP.

I'm still getting the same error and i'm hoping someone sees something from these settings. Brad Groux, any chance you can check your BIOS settings against mine since it appears my laptop should be able to support virtualization.
0
McKnifeCommented:
Try these: First generation machine and not second. Also use a different OS.
0
Lee W, MVPTechnology and Business Process AdvisorCommented:
The settings as labeled may not have the same names in BIOS - take your phone or a digital camera and take some pictures of your BIOS.  (Before that, enable Intel VT-d)
0
eagle3344Author Commented:
McKnife, i'm not really sure what you mean. Can you explain a little more?

Lee, here are the pic of my BIOS.
BIOS.zip
0
McKnifeCommented:
About generations, see
GenerationSelectionDifferent OS: I meant, try with a different guest OS setup ISO.
0
Lee W, MVPTechnology and Business Process AdvisorCommented:
Well, you've got me stumped... can you run BCDEDIT in a command prompt and post the results.
0
eagle3344Author Commented:
Sorry for the delay guys...here is the results of BCDEDIT

C:\Windows\system32>bcdedit

Windows Boot Manager
--------------------
identifier              {bootmgr}
device                  partition=C:
description             Windows Boot Manager
locale                  en-US
inherit                 {globalsettings}
integrityservices       Enable
default                 {current}
resumeobject            {e2bf9873-8941-11e0-8767-f0def152a605}
displayorder            {current}
toolsdisplayorder       {memdiag}
timeout                 30

Windows Boot Loader
-------------------
identifier              {current}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Windows 8
locale                  en-US
inherit                 {bootloadersettings}
recoverysequence        {e2bf9875-8941-11e0-8767-f0def152a605}
integrityservices       Enable
recoveryenabled         Yes
allowedinmemorysettings 0x15000075
osdevice                partition=C:
systemroot              \Windows
resumeobject            {e2bf9873-8941-11e0-8767-f0def152a605}
nx                      OptIn
bootmenupolicy          Standard
hypervisorlaunchtype    Auto
0
eagle3344Author Commented:
McKnife, I don't believe the issue is caused by the guest OS in any way as I setup a generic VM without attaching a VHD and tried to start it and I got the same error. My guess is the problem is in the BIOS, but I cannot pinpoint what the problem is. I appreciate the suggestions!
0
McKnifeCommented:
But the generations, what about those?
0
eagle3344Author Commented:
I didn't see that in my setup wizard:

hyperV
0
McKnifeCommented:
I am sorry, missed that you wrote "windows 8"... - the 2nd generation VMs are possible with win8.1, not with 8. Why not upgrade to 8.1, it's free, maybe your problem will also vanish as hyper-v gets updated.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
eagle3344Author Commented:
Mcknife, I upgraded to 8.1 and all works well now...thanks so much! sometimes the easiest, most obvious is not the most obvious! Much appreciated!
0
McKnifeCommented:
Super.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 8

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.