Solved

rePORTAL Not Printing Crystal Formula Fields

Posted on 2014-09-04
10
349 Views
Last Modified: 2014-09-10
A report I created using Crystal runs well in Crystal but when running it via rePORTAL (Shahrabani + Associates), none of my formula fields will print. See image below for example...

http://s32.photobucket.com/user/tompreston75/media/rePortal_zps1a9fa759.jpg.html

Any ideas as to what may be causing this?
0
Comment
Question by:Bad_Fish
  • 5
  • 4
10 Comments
 
LVL 100

Expert Comment

by:mlmcc
ID: 40304238
No idea.

Have you checked the rePortal site for help?
I looked at their site but I don't see any FAQ or HELP options.

What are the formulas in question?

mlmcc
0
 

Author Comment

by:Bad_Fish
ID: 40304257
Yes...I found an infrequently used forum and posted the same question there. However, based on the time between posts, I don't expect to hear anything soon.

For documentation purposes; if anyone else needs the rePORTAL forum it can be bound at http://forums.reportalsoftware.com. You must enter the following credentials for initial access...

Username: forumuser
Password: reportal12

...after that, users can register with their chosen username.

As for the formulas; they are quite simple. Here are all four...

1) {AZInvoiceDetail.azid_UnitPrice}*{AZInvoiceDetail.azid_QtyInvoiced}

2) {AZInvoiceDetail.azid_UnitCost}*{AZInvoiceDetail.azid_QtyInvoiced}

3) ({AZInvoiceDetail.azid_QtyInvoiced}*{AZInvoiceDetail.azid_UnitPrice})-({AZInvoiceDetail.azid_QtyInvoiced}*{AZInvoiceDetail.azid_UnitCost})

4) ((({AZInvoiceDetail.azid_UnitPrice}-{AZInvoiceDetail.azid_UnitCost})/{AZInvoiceDetail.azid_UnitPrice})*100)

Each formula is in a conditional statement. For example, the full formula for #1 above is...

if isnull({AZInvoiceDetail.azid_UnitPrice}) then
    0
else
    {AZInvoiceDetail.azid_UnitPrice}*{AZInvoiceDetail.azid_QtyInvoiced}

...but that shouldn't matter.
0
 
LVL 100

Expert Comment

by:mlmcc
ID: 40304563
As best I can tell, rePortal is just a viewer/portal and doesn't change the report in any way.  DO you know if that is true?

I don't see anything in the formulas that jumps out as an issue.

mlmcc
0
 

Author Comment

by:Bad_Fish
ID: 40304705
Reportal is used in conjunction with Sage CRM and I don't believe that it changes the report...but it runs in Crystal and not in rePortal...so maybe it does.

I'm working with the author now so I'll report back with the solution.
0
 
LVL 34

Expert Comment

by:James0628
ID: 40305545
FWIW, the full formula that you posted checks to see if azid_UnitPrice is null, but it doesn't check azid_QtyInvoiced.  If azid_QtyInvoiced was null (and you're not converting database null values to default values), the formula wouldn't show.  And your first 3 formulas use azid_QtyInvoiced, so a null field could explain those.  OTOH, the 4th calculation doesn't use it, so it wouldn't seem to explain that one.

 IAC, it would be easy enough to change the first formula to check azid_QtyInvoiced for nulls too, and see if you get 0's on the report.

 James

if isnull({AZInvoiceDetail.azid_UnitPrice}) or IsNull ({AZInvoiceDetail.azid_QtyInvoiced}) then
     0
 else
     {AZInvoiceDetail.azid_UnitPrice}*{AZInvoiceDetail.azid_QtyInvoiced}

Open in new window

0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 100

Expert Comment

by:mlmcc
ID: 40305764
In looking at his image of the report the one shows data for the formulas but the other doesn't.  Assuming it is the same report and data there is an issue with rePortal.

mlmcc
0
 

Accepted Solution

by:
Bad_Fish earned 0 total points
ID: 40306403
Updating to the latest Acrobat product solved this problem.
0
 
LVL 100

Expert Comment

by:mlmcc
ID: 40306467
Did the "working" version have a newer Acrobat?

mlmcc
0
 

Author Comment

by:Bad_Fish
ID: 40306500
The new version of Acrobat solved it.
0
 

Author Closing Comment

by:Bad_Fish
ID: 40314023
In the course of attempting to resolve this problem, I updated my computer to the latest version of Acrobat. That solved the problem.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Crystal Reports: 5 Tests for Top Performance It is complete, your masterpiece report.  Not only does it meet your customer’s expectations, it blows them out the water, all they want is beautifully summarised and displayed in a myriad of ways. …
I hate sub reports and always consider them the last resort in any reporting solution.  The negative effect on performance and maintainability is just not worth the easy ride they give the report writer.  Nine times out of ten reporting requirements…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now