NTFS access to only one file

using Windows Server 2003 Standard as a file server.  we have a consultant coming in and they need access to only one file on our file server.  'Allow inheritable permissions' is on.  Is there a way to give this user 'modify' permissions on only one file (ie. 'document1.doc') and nothing else?

\\server1\shared\folder1

document1.doc
document2.doc
document3.doc
LVL 1
jkimzlgAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hypercat (Deb)Commented:
Create a separate login for that user that is NOT a member of any of the groups that are included in the inherited permissions.  Then give that user account Traverse Folder/Execute File permissions to the upper level folders and Modify permissions to only that one document. Also be sure that if there are any share permissions involved that those are set to Read for this user account.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
yo_beeDirector of Information TechnologyCommented:
I not sure you want to use Traverse/Execute setting because this will allow users to open files within the parent folder and if allowed to propagate to subdirectory then the user will be allow to open the files in the subs.

I would use List Content/read data instead then give the rights you want to the files or you can just give rights to a user account as describe by HyperCat to just the three files.  Then give them the complete UNC path to the three files.

So do not give any rights to consultant1 accept at the file level.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.