GUI in Windows Server 2012 Standard Disappeared After Machine Was Joined to Domain. Are There GPO Settings that Could Cause This?

Yesterday, we rename and joined a Server 2012 (Standard) server to a new domain-OU (with DNS suffix changed). Afterwards, we noticed that the GUI became unavailable; now, it only displays the command-prompt after login.

Has anyone had this experience? Is there a possible fix for it?
U-g-oAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MIRSYSCommented:
Well sounds like explorer is not starting , or the gui got uninstalled again..
Have you just tried "explorer.exe" in the prompt?

Otherwise you could run the following to reinstall the shell:

Dism /online /enable-feature /featurename:ServerCore-FullServer /featurename:Server-Gui-Shell /featurename:Server-Gui-Mgmt

I don't think gpo is causing this, cause you would have other servers with this issue?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MaheshArchitectCommented:
I think you have removed some how GUI (User interfaces and infrastructure)  feature from  server
U need to reinstall it.

If this is domain joined server, you can add it to server manager pool on another server and from there install GUI
http://www.howtogeek.com/111967/how-to-turn-the-gui-off-and-on-in-windows-server-2012/

I am not sure how it was get removed automatically, ideally it should not unless some one has manually remove it.
0
U-g-oAuthor Commented:
Hi MYRSIS, thanks a lot. Your solution worked, just with a little tweak.  The first run failed, because of some missing dependencies. However, adding '/all' just after '/enable-feature' fixed this. Thanks a lot.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.