Solved

PDF attachement shown as WINMAIL.DAT

Posted on 2014-09-05
38
2,200 Views
Last Modified: 2014-09-10
Hi,
 
 I have an user with Office 2010 (connected to SBS2011/Exchange 2010).
 When he sends emails with PDF files attached, he says that in the recipients email program, those PDF files are shown as "winmail.dat".

 Is this setting issue or sender's outlook or the setting in recipient's email program or something else?
0
Comment
Question by:sglee
  • 19
  • 13
  • 3
  • +1
38 Comments
 
LVL 1

Expert Comment

by:Orcatec Operations Team
ID: 40305840
Hi there!

In almost every instance, this is due to the Outlook sender sendin an email in rich text format (RTF).

Here is a quick 'how to' to clean this up.

http://email.about.com/od/outlooktips/qt/Prevent_Winmail_dat_Attachments_from_Being_Sent_in_Outlook.htm

Please let me know if this does not fix the issue.

There are a few more options.

Cheers!

Bri...

Brian Holcomb
0
 
LVL 1

Expert Comment

by:Orcatec Operations Team
ID: 40305847
Also, keep in mind. The email *sender* is the problem. Not the recipient in this instance.

Cheers,

Bri...


Brian Holcomb
0
 

Author Comment

by:sglee
ID: 40305852
"In almost every instance, this is due to the Outlook sender sendin an email in rich text format (RTF)." --> that was what I was suspecting. Let me connect to the user computers and take a look the settings in their Outlook 2010.
0
 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 500 total points
ID: 40305867
It is not a sender issue - it is an incompatibility issue between sender and recipient.

Usually this happens when sending from Exchange to a non-Exchange system and Mac users have this problem regularly.

The issue is to do with TNEF (Transport Neutral Encapsulation Format) and this can be disabled when sending to a particular domain.

New-RemoteDomain -Name ProblemDomain -DomainName problemdomain.com
Set-RemoteDomain ProblemDomain -TNEFEnabled $false

Running the above commands in the Exchange Management Shell should tell Exchange to send out email without TNEF enabled and then the recipient shouldn't have a problem.

Alan
0
 
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 40305920
Hi sglee,
This is a nasty problem that has been around a long time. Here are a couple EE threads that I've participated in that may help you (I'm sure there are others — I suggest searching EE for winmail and/or winmail.dat):

http://www.experts-exchange.com/Software/Internet_Email/Email/Q_28454752.html
http://www.experts-exchange.com/Software/Office_Productivity/Groupware/Outlook/Q_28129365.html

Regards, Joe
0
 

Author Comment

by:sglee
ID: 40305925
@Orcatec
I checked user's outlook 2010 and confirmed that it is using HTML format to send these emails out.
@Alan
They never had these problems until this week. They never had "File Server" in the office with 5 PCs. I just installed SBS2011/Exchange2010 last week and this started happening.
But then I manage several SBS2011 sites, but never had to run that command either.
"New-RemoteDomain -Name ProblemDomain -DomainName problemdomain.com
Set-RemoteDomain ProblemDomain -TNEFEnabled $false"

Just now I was told by the user that most (not all) winmail.dat problems were the emails sent directly by Quickbooks. The user sends invoice directly from Quickbooks. But then they never had this issue until I installed SBS2011.
0
 

Author Comment

by:sglee
ID: 40305934
@Joe
Are you suggesting I reinstall Outlook?
0
 
LVL 1

Expert Comment

by:Orcatec Operations Team
ID: 40305943
Hi there @sglee.

Everyone above is absolutely correct and a bit more granular in their answers than me.

Since QB is sending the emails, try this:
https://support.quickbooks.intuit.com/support/Articles/SLN40996

@Alan is correct with the global exchange config.

The winmail.dat/TNEF can be decoded with uudecode or just about any online or downloadable base64 decoder, but that's a hassle.

Most of the time I see the RTF format issue, whereas in the past, I have seen more issue with poor translation between microsofts laughable 'transport neutral' encapsulation format, when traversing through linux-based UTF-8 mail transfer agents, or into Lotus Notes.

Check that link and see if maybe that will point you in the right direction.

Hope it helps.

Cheers,
Bri...

Brian Holcomb
0
 

Author Comment

by:sglee
ID: 40305948
So far what I can tell is:
(1) User's Outlook 2010 sends out emails in HTML format.
(2) The user (has been doing) emails invoices out directly from Quickbooks and received no complains from recipients in the past until I installed SBS2011 last week. Now this problem started happening this week.
(3) I had the user open Quickbooks and email me invoice directly. I received the email with invoice in PDF and I was able to open it just fine. I have two computers - one with Outlook 2003 and the other one with Outlook 2010.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40305949
We have the same issue with QB when emailing invoices.  If you save the .PDF rather than have QB email it and then attach it to an email, then it sends fine, but if you email it directly via QB, then it goes wrong.

Not sure if we have looked too heavily into the problem / resolved it, but then I don't do the accounts so it doesn't bother me ;)

We have Exchange 2010 locally here (and I manage dozens of SBS 2011 servers) and I have only had to only run those commands for a couple of domains on a couple of servers we / our customers send to - it's not a big problem, but that is a workable solution to the problem in general, but not necessarily a QB generated problem.
0
 
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 40305959
> Are you suggesting I reinstall Outlook?

That's one approach that has worked in some cases. As I mentioned in one of the earlier questions on the same subject, it is an incredibly common problem and there is no one solution that works for everyone. If you search EE by putting "winmail.dat" in the search box, you will get 870 hits (up by 100 in the last year). If the reinstall doesn't fix it, then read some of the other threads and try some of the fixes that worked for other members. This is one of those problems that doesn't have a single, guaranteed solution — it is definitely a "YMMV" situation. Regards, Joe
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40305988
Prior to you installing SBS 2011 - how were emails flowing from the QB PC to the world?  Presumably via a 3rd party email server using QB email not via the Exchange Server?

Have you tried my solution yet to see if that works - it is the easiest one to implement?

Alan
0
 

Author Comment

by:sglee
ID: 40306005
@Alan
"Prior to you installing SBS 2011 - how were emails flowing from the QB PC to the world? " --> Apparently emailing invoices directly from Quickbooks is something that they have been doing in the past without a problem (again until I installed SBS2011 where outgoing emails are handled by Exchange). If I google Winmail.dat with QB, I see a lot of articles too.

I really hesitate to make changes in Exchange server simply because I did not have to do it on any other SBS2011 sites that I manage ... can you give me sample text for  the cmdlet "New-RemoteDomain -Name ProblemDomain -DomainName problemdomain.com
Set-RemoteDomain ProblemDomain -TNEFEnabled $false"?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40306083
You aren't making and exciting changes when running those commands - they just tell Exchange to send out emails to the relevant domain without TNEF enabled.

An example set of commands for the domain contoso.com would be:

New-RemoteDomain -Name Contoso -DomainName contoso.com
Set-RemoteDomain Contoso -TNEFEnabled $false

You can re-enable TNEF for that domain (if you want to) by running the following command:
Set-RemoteDomain Contoso -TNEFEnabled $true

Alan
0
 

Author Comment

by:sglee
ID: 40306146
@Alan
If this command requires the spelling of "recipient's domain name", then I have to do this, so to speak, "forever", whenever they have to send invoice to new customer who runs into the same problem?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40306168
Correct - but it's not something we have had to do that many times for our business and we support hundreds of customers that we Invoice regularly.
0
 

Author Comment

by:sglee
ID: 40308977
OutlookHotmailHere is an interesting discovery.
I sent an email from the user's Outlook to myself - one to my business email account and  Hotmail and the user has signature (that is embedded whenever new email is composed and) that consists of text (name, address .. etc) and one logo/graphic.
When I opened test email in my Outlook 2010, the logo comes as attached and the email is opened as "Plain Text" whereas Hotmail (on the browser) showed the logo along with text.
His Outlook 2010 is set to use HTML as default mode. So is my Outlook.
I wonder why my outlook opened his email in Plain Text.
0
 

Author Comment

by:sglee
ID: 40312640
Alan,
 
 I gathered domain names from those email recipients who are receiving Winmail.dat and those are gmail.com yahoo.com earthlink.net,  aol.com so far.
 What is in common, at least, among these domain name is that these are big emails service companies. I don't mind running TNEF on these because it is only several.
 Can you check the syntax of the command?

New-RemoteDomain -Name AOL -DomainName aol.com
Set-RemoteDomain AOL -TNEFEnabled $false

and I just repeat the same for each domain?
Can I do this in Exchange Management screen?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40312642
That's correct for the syntax and just run it in the Exchange Management shell.

Alan
0
Are your corporate email signatures appalling?

Is it scary how unprofessional your email signatures look? Do users create their own terrible designs and give themselves stupid job titles? You can make this a lot easier for yourself by choosing an email signature management solution from Exclaimer today.

 

Author Comment

by:sglee
ID: 40312651
Alan,
 
 How do I verify if the command is executed successfully?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40312654
If you see no errors - it worked!
0
 

Author Comment

by:sglee
ID: 40312658
ok. I ran them and here is the result:

[PS] C:\Users\wgladmin\Desktop>New-RemoteDomain -Name AOL -DomainName aol.com

Name                           DomainName                                   AllowedOOFType
----                           ----------                                   --------------
AOL                            aol.com                                      External

[PS] C:\Users\wgladmin\Desktop>Set-RemoteDomain AOL -TNEFEnabled $false
[PS] C:\Users\wgladmin\Desktop>New-RemoteDomain -Name YAHOO -DomainName yahoo.com

Name                           DomainName                                   AllowedOOFType
----                           ----------                                   --------------
YAHOO                          yahoo.com                                    External

[PS] C:\Users\wgladmin\Desktop>Set-RemoteDomain YAHOO -TNEFEnabled $false
[PS] C:\Users\wgladmin\Desktop>New-RemoteDomain -Name EARTHLINK -DomainName earthlink

Name                           DomainName                                   AllowedOOFType
----                           ----------                                   --------------
EARTHLINK                      earthlink                                    External

[PS] C:\Users\wgladmin\Desktop>Set-RemoteDomain EARTHLINK -TNEFEnabled $false
[PS] C:\Users\wgladmin\Desktop>New-RemoteDomain -Name GMAIL -DomainName gmail

Name                           DomainName                                   AllowedOOFType
----                           ----------                                   --------------
GMAIL                          gmail                                        External

[PS] C:\Users\wgladmin\Desktop>Set-RemoteDomain GMAIL -TNEFEnabled $false
0
 

Author Comment

by:sglee
ID: 40312661
I will ask the user to send emails to the recipients with PDF attachments again.
I will post the result.
0
 

Author Comment

by:sglee
ID: 40312676
Alan,
 
 I have a question. After running these commands, I realized  that I forgot to spell out ".com" on Gmail and Earthlink domains.
So when I tried to run it again with correct syntax (New-RemoteDomain -Name EARTHLINK -DomainName earthlink.net), I got an error.

Should I leave it as it is?

[PS] C:\Users\admin\Desktop>New-RemoteDomain -Name EARTHLINK -DomainName earthlink.net
Active Directory operation failed on DC1.wgl.local. The object 'CN=EARTHLINK,CN=Internet Message Formats,CN=Global Sett
ings,CN=First Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=wgl,DC=local' already exists.
    + CategoryInfo          : NotSpecified: (0:Int32) [New-RemoteDomain], ADObjectAlreadyExistsException
    + FullyQualifiedErrorId : AC455B,Microsoft.Exchange.Management.SystemConfigurationTasks.NewRemoteDomain
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40312715
If you put the wrong .extension, just create a new command with a new RemoteDomainName and run that for the correct .extension.

If you want to see a list of tnefenabled:$false domains, run this command:

Get-RemoteDomain | Where {$_.TNEFEnabled -eq $false}
0
 

Author Comment

by:sglee
ID: 40312730
Alan,

  I ran that command "Get-RemoteDomain" and as you can see, I made a mistake on Earthlink and Gmail. How can I remove these entries from the list?

[PS] C:\Users\admin\Desktop>Get-RemoteDomain | Where {$_.TNEFEnabled -eq $false}

Name                           DomainName                                   AllowedOOFType
----                           ----------                                   --------------
AOL                            aol.com                                      External
YAHOO                          yahoo.com                                    External
EARTHLINK                      earthlink                                    External
GMAIL                          gmail                                        External
SBCGLOBAL                      sbcglobal.net                                External
HONDA                          honda.com                                    External
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40312745
Run the following:

Remove-RemoteDomain -identity earthlink
Remove-RemoteDomain -identity gmail
0
 

Author Comment

by:sglee
ID: 40312750
I added these commands. Apparently Exchange remembers the names used previously even after Re-enabled them.

New-RemoteDomain -Name EARTHLINK1 -DomainName earthlink.net
Set-RemoteDomain EARTHLINK1 -TNEFEnabled $false

New-RemoteDomain -Name GMAIL1 -DomainName earthlink.net
Set-RemoteDomain GMAIL1 -TNEFEnabled $false
0
 

Author Comment

by:sglee
ID: 40312754
Ah ... Got you. Thank you.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40312759
Looking good.

Any test emails with PDF's sent yet?  If so - did they get received happily without the winmail.dat attachments?
0
 

Author Comment

by:sglee
ID: 40312775
I told the user to send emails again to the recipients and waiting for the results.

For testing, while adding those domain names, I added my domain name too and I can tell the difference.
Before running TNEF commands with my domain name, I remotely connected to my customer's OUTLOOK and sent an email to my email account. He has two logos in his signature. All those logs did show in Attachment section.
But now, after running TNEF command for my domain name, I can see those logos correctly above the rest of his signature text (name, address, ph# ... etc).
So hopefully I will hear good news!
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40312780
Sounds promising and will be a permanent fix for each domain.

Easy to add others as and when required too.

Alan
0
 

Author Comment

by:sglee
ID: 40312791
Alan,
 
 I manage several SBS2011 network and I am wondering why this is happening on this particular SBS2011 Exchange other than the fact that (1) This is newest SBS2011 install  (2) No other customer of mine sends invoices directly from QuickBooks?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40312843
It's something to do with the way QB works (or doesn't).  If you install QB on another site and send emails out via Exchange, the same thing will happen.
0
 

Author Comment

by:sglee
ID: 40312846
Got you. Thanks for your help and I appreciate it.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40312849
You're welcome.
0
 

Author Comment

by:sglee
ID: 40315404
The PDF invoices generated by Quickbooks are delivered to the recipients in those domains  correctly.
 Again thank you for your help.
0
 
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 40315422
Hi Alan,
This is some great stuff! Worthy of an article, for sure. :)  In any case, thanks for the explanations — I learned a lot! Regards, Joe
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
Is your Office 365 signature not working the way you want it to? Are signature updates taking up too much of your time? Let's run through the most common problems that an IT administrator can encounter when dealing with Office 365 email signatures.
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …
how to add IIS SMTP to handle application/Scanner relays into office 365.

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now