Solved

Problem naming FQDN when creating a forest for Active Directory

Posted on 2014-09-05
4
141 Views
Last Modified: 2014-09-16
I have a WIndows machine without a Forest or a Domain, just a name and a Workgroup.

Name:        Field
Workgroup:   abc

Open in new window

                                 
So now I want to add a Forest and a Domain to the machine, such that its FQDN will be field.yyy.xxx.zzz.com

So I start by creating a Forest following these instructions:

http://technet.microsoft.com/en-us/library/cc755059%28v=WS.10%29.aspx

I get as far as task 11 (Put in a FQDN for the Forest), I put in the desired name, as opposed to the name and workgroup:

field.yyy.xxx.zzz.com

Open in new window

                                 

I hit return and the system says the following:

The default NetBIOS Domain name "field0" was selected due to name conflicts on the network
                                 
So apparently Windows AD thinks there is some sort of IP resolution conflict.  After repeated attempts to resolve the issue, I come to a potential solution:  I remove the DNS and the Gateway.

My thinking is that if there is no DNS, it can not find a name conflict.  So I delete the DNS and Default Gateway, and I reboot the machine to hopefully flush any IPTABLES entires

So I try adding a forest again, and give the following FQDN:

field.yyy.xxx.zzz.com

Open in new window

                               

After I I hit return and the system reports:

The default NetBIOS Domain name "field0" was selected due to name conflicts on the network

Same thing as before even though there is no DNS.

Any idea of what I should do from this point ?

Thanks
0
Comment
Question by:Anthony Lucia
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 29

Expert Comment

by:becraig
ID: 40306755
Simply create your domain as such
or field1.local
You will have issues later with your testing which I would suggest you avoid at this point.
0
 
LVL 7

Expert Comment

by:Delete
ID: 40306878
NetBIOS will also broadcast for responses so simply removing DNS will not allow you to bypass the fact that there already exists a machine with the same NetBIOS name.

So you really have three options:
1. Change the NetBIOS name of the machine you are trying to promote to a Domain Controller
2. Change the NetBIOS name of the conflicting machine
3. Change the subnet of the Domain Controller

Another option I forgot:
4. Disable NetBIOS over TCP/IP on the Domain Controller's NIC
Go to the properties of the NIC -> Select Internet Protocol Version 4 (TCP/IPv4) -> Select Properties -> Advanced -> WINS tab -> Select Disable NetBIOS over TCP/IP
0
 

Author Comment

by:Anthony Lucia
ID: 40310691
Previously when I put in a FQDN, the install process would take about 30 seconds, and then produce the following error:

The default NetBIOS Domain name "field0" was selected due to name conflicts on the network 

Open in new window


This time I followed the instructions given, as follows

Disable NetBIOS over TCP/IP on the Domain Controller's NIC
Go to the properties of the NIC -> Select Internet Protocol Version 4 (TCP/IPv4) -> Select Properties -> Advanced -> WINS tab -> Select Disable NetBIOS over TCP/IP 

Open in new window


Then I rebooted the machine

Then I entered the FQDN again, but instead of taking 30 seconds, it took no time at all, and displayed the following warning:

The default NetBIOS Domain name "field0" was selected due to name conflicts on the network 

Open in new window


So the NETBios is not finding a conflict, because it can not broadcast, as evidenced by the fact taht it takes 0 seconds to tell me there is a conflict instead of the usual 30 seconds when the NETBios is enabled for the NIC

I though that IPTABLES would not be an issue since I rebooted

How can I proceed to eliminate this error / warning ?

Thanks
0
 
LVL 29

Accepted Solution

by:
becraig earned 500 total points
ID: 40310708
Ok maybe you should give my simple idea a try

1) Ensure the server is configured with it's own primary address as the dns server
2) Ensure the dns server service is running with no issues
3) Simply enter your fqdn for your domain (field.local) or whatever you plan to use.

II would suggest trying something unique that you have not tried to this point (as far as a name) since something else may be happening here that we are not aware of.


you should also be able to verify dns is working by simply running nslookup at a prompt and see what comes back.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

by Nathan Brom/Bromy2004 Introduction There are numerous websites out there for any different type of program you can imagine.  Of those, you'll need to decide which ones are legitimate and aren't trying to steal your money or infect your comput…
The password reset disk is often mentioned as the best solution to deal with the lost Windows password problem. In Windows 2008, 7, Vista and XP, a password reset disk can be easily created. But besides Windows 7/Vista/XP, Windows Server 2008 and ot…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question