Install software with GPO on Windows 2012

We have a Server 2012 and 40 Windows 7 Pro Client all with roaming profiles.

I have issues to deploy software using GPO
I used this film (windows 2008): https://www.youtube.com/watch?v=jXAz6vrWMP0
Se attached
There is access to share
I created a computer group and moved all computers in there
I created a GPO and attached to the computer group
I created GPO to disable to UAC
Ran gpupdate /force on server

Now i restart the PC
It reboots, nothing happens
I reboot again as sometimes I have seen it needs 2 reboot, nothing happens

hm
I run gpupdate /force on the windows 7 and it does not say that GPO has been updated
The PC i am testing on is for sure in the Computer Group

This works through....
If i disable the GPO in the Computer Group and link it to the usergroups "teachers" and "students", it works.
However I have read best practice is to link it to the computer group so its installed on reboot,no mather who logs in.

Any idea where to go from here?
gpo-software.jpg
morten444Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cliff GaliherCommented:
In the gpeditor there are two main sections. Computer police and user policies. Computer policies always apply to computer objects. You can't make them apply to user objects. User policies always apply to user objects. You can't make them apply to computer objects.

If you add a setting to the user section and then link the policy to an OU with only computers, those settings will never get applied. They are user settings and the only objects that are linked are computers.

So when you say these settings are applied at logon (and not computer startup) and work when linked to an OU with users, it sounds like you missed that fundamental difference.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Neeraj KumarSystem adminCommented:
1. Check the event viewer if there is any error related to group policy on client machine.

2. Run Rsop.msc wizard and check whether configured policy is showing or not.

3. Group policies start before the network stack is fully up. There is a setting that can fix that: Computer Configuration\Policies\Administrative Templates\System\Logon\Always wait for the network at computer startup and logon.
0
morten444Author Commented:
Hi. Sorry was away for some days
Cliff: Thanks for feedback. If you see the attached picture in the post it all looks right to me.
It is applied to computer, not used.
When i did the test with used, i moved it over to user. I dont get why its not applied.

Neeraj: Thanks for feedback. There is no event viewer errors.  The fix you talk about.. i should apply that locally on each windows PC' local GPO or via the Servers GPO Manager?

Thanks
0
Neeraj KumarSystem adminCommented:
To apply on each pc you need to apply it via Server GPO manager.

If you need to do testing on one machine you can do via local gpo.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.